Closed Bug 554793 Opened 13 years ago Closed 13 years ago

Objects with no proto have different shapes

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: jorendorff, Unassigned)

Details

shapeOf(evalcx("lazy")) was stable, but the fix for bug 497789 changed that. Now each new sandbox object has a different shape.

This causes js1_8_1/extensions/regress-466905-05.js to fail.

Separately, shapeOf(Object.create(null)) is different every time too. This is older behavior. Maybe it always did that.
It's a feature, not a bug.  --> RESO INVALID
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.