Windows not recognized as windows belonging to one app

VERIFIED DUPLICATE of bug 29856

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 29856
18 years ago
13 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

({helpwanted})

Trunk
Future
Sun
Solaris
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 2000100421-M18 (Solaris, Sparc)

Different windows created by Mozilla aren't recognizable (for the window
manager) as windows belonging to one app. As a result, the system keyboard
shortcut for switching between the windows on one app does not work.

Steps to reproduce:
1) Open another browser window if you haven't two or more windows open already
2) Press Alt-F6

Reproducible always.

Actual results: Nothing

Expected results: Expected another Mozilla window to become active.

Comment 1

18 years ago
hmm on linux, it seems the WM doesnt' only see it as one APP, but even as one
window. There are no difference between window groups (classes?), which means
that minimizing browser also minimizes mailnews (if WM is told to minimize
groups of windows that "belong" to eachoter). Same WM handles Netscape 4.7* just
fine, mening mailnews and browsers cluster up as groups, and minimizing browser
still leaves mailnews open.
claudius->window controls?
QA Contact: sairuh → claudius

Comment 3

18 years ago
this is soooooo, a toolkit thing...(well likely anyways)
Assignee: ben → trudelle
Component: XP Apps: GUI Features → XP Toolkit/Widgets
QA Contact: claudius → jrgm

Comment 4

18 years ago
->danm/future
Assignee: trudelle → danm
Target Milestone: --- → Future

Updated

18 years ago
Keywords: helpwanted

Comment 5

18 years ago
I think this boils down to be a side-effect of bug 29856:
"*nix only : Window Class the same for all mozilla windows".
Or a dup, rather.

Updated

15 years ago
Depends on: 29856

Updated

13 years ago
Assignee: danm.moz → nobody

Comment 6

13 years ago
This is a side effect of the window class being set incorrectly, as suggested in
the previous comment.

*** This bug has been marked as a duplicate of 29856 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.