File system navigator window works wrong with desktop shortcuts in Linux

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: taspelk, Unassigned)

Tracking

3.6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9.2.0) Gecko/20100115 SUSE/3.6.0-1.2 Firefox/3.6

In Linux the desktop shortcuts (to a folder) (called "Link to Location (URL)" in distros that use KDE desktop environment and "(place) launcher" in distros that use GNOME), though work well in the operative system ((double) clicking on them opens Konqueror or Nautilus with the route as the target folder of the shortcut), have this problem in Firefox:
+ when one is on a web page and clicks on a "Browse..." button a file system browser window opens. If one then clicks on Desktop and then on the shortcut, instead of forwarding to the target folder, the file system browser window closes, leaving as the route the one of the shortcut (instead of the target folder of that shortcut).

(There is no problem in Firefox under Windows).

Reproducible: Always

Comment 1

8 years ago
Firefox is a gnome application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 266600
(Reporter)

Comment 2

8 years ago
I've looked in the Wikipedia article about Firefox and doesn't say that is a GNOME application. Neither is said that in the article about GNOME.

The problem happens in all the Linux distros I've tried: both with the GNOME desktop environment and the KDE one.

The bug 266600 seems to deal with something else: the download manager.

Please, if you could unmark this bug as duplicate so someone else could help on this. Or, please, explain why you marked it as duplicate of bug 266600.

Thank you.
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

8 years ago
I've been able to unmark it as duplicate. I hope someone can help now.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 4

8 years ago
There is a workaround:

Instead of creating a "Link to Location (URL)" (KDE) or "(place) launcher" (GNOME), open a terminal and create a symbolic link:

ln -s /the/destination/folder ~/Desktop/link

( Taken from http://www.slax.org/forum.php?action=view&parentID=59037 )

FOR KDE based distros: in the file system navigator window, to see the just created symlink, it may be necessary to click on the refresh button.
(Reporter)

Comment 5

8 years ago
I've learned that Firefox for Linux uses GTK dialogs, no matter if the Linux distro uses KDE or GNOME. I thought that KDE based distros didn't have GTK packages but I've seen that they have some.

So probably this bug is to be solved by GTK developers. There is a bug about this opened in GNOME's bugzilla.

Comment 6

8 years ago
Correct the file browse dialogs are native GTK.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.