When resolving as duplicate, do not add reporter to cc list of master bug if reporter is disabled

RESOLVED WONTFIX

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: mrbball, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009073021 Firefox/3.0.13
Build Identifier: 3.4.4

When marking one bug as a duplicate of another, the reporter of the
duplicate is generally added to the cc list of the master (if they are
allowed to see the master and they were not the reporter of the master).
However, adding the reporter of the duplicate to the cc list of the
master seems inappropriate if that reporter has been disabled.

The process of adding the reporter of the duplicate to the cc list of
the master should either:

1. Be skipped in the same way it is skipped if the same user is the
   reporter of both duplicate and master.
OR
2. Prompt the user making the change for confirmation, in the same way
   they are prompted for confirmation if the reporter of the duplicate
   cannot see the master bug.

I prefer the first option, since I don't foresee a situation where a
disabled user should ever be added to the CC list (at least not on my
local installation).

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 435185 [details] [diff] [review]
v1
Attachment #435185 - Flags: review?(mkanat)

Comment 2

8 years ago
There are situations in which disabled users should be added to the CC list of bugs--mostly if somebody is watching that disabled user. If the user has bugmail disabled, it should be generally harmless to have them added to the CC, and it still allows watchers to receive email.
(Reporter)

Comment 3

8 years ago
So are you saying you want to leave it functioning completely as-is or
would you willing to have it prompt the user, as in case #2 (reporter of
duplicate can't see master)?  Configurable?

This should be a fairly rare occurrence.

Comment 4

8 years ago
  Um, I really appreciate the patch, but I think I'd prefer to leave it as-is for now. I bet it'd be a really simple extension to write, though, if you wanted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Attachment #435185 - Flags: review?(mkanat)
(Reporter)

Comment 5

8 years ago
Thanks, but it's way not worth the hassle of an extension.
You need to log in before you can comment on or make changes to this bug.