Elements should be visible even if mask/clip-path/filter refer invalid resources

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: emk, Assigned: emk)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

9 years ago
Reproducable: always

Steps to reproduce:
1. Enable JavaScript.
2. Open the test case.
3. Disable JavaScript.
4. Open the test case again.

Actual result:
An element is not rendered at all when JavaScript is disabled.

Expected result:
An element should be drawn without SVG effects if JavaScript is disabled.

Because of this bug, it's very hard to write a fallback code in case referred resource is missing or invalid.
(Assignee)

Comment 1

9 years ago
Created attachment 435192 [details]
Testcase
(Assignee)

Comment 2

9 years ago
Created attachment 435194 [details] [diff] [review]
patch

>  if (!isOK) {
>    // Some resource is missing. We shouldn't paint anything.
>    return;
>  }
Why not?
Assignee: nobody → VYV03354
Status: NEW → ASSIGNED
Attachment #435194 - Flags: review?(roc)
I've talked to bz once and he said that this behaviour is actually according to the SVG spec, if I recall correctly.
But I agree that keeping the element visible would be much better in practice.
This is according to the SVG specification. SVG 1.1 2nd edition is proposing that this be changed for clipPath only so if you want to raise another bug just for clipPath you can, although the 2nd edition  is still a work in progresss so we haven't implemented anything that conflicts with SVG 1.1 and that says missing resources result in no drawing.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Attachment #435194 - Flags: review?(roc) → review-
Since applying SVG effects to HTML isn't specced yet, could we change the behaviour there without violating the SVG spec?
(In reply to comment #2)
> Created an attachment (id=435194) [details]
> patch
> 
> >  if (!isOK) {
> >    // Some resource is missing. We shouldn't paint anything.
> >    return;
> >  }
> Why not?

We need to render this correctly

http://www.w3.org/Graphics/SVG/Test/20061213/htmlObjectHarness/full-filters-felem-01-b.html
(In reply to comment #5)
> Since applying SVG effects to HTML isn't specced yet, could we change the
> behaviour there without violating the SVG spec?

So SVG works one way and HTML the opposite. A receipe for complete confusion.
status1.9.2: ? → ---
You need to log in before you can comment on or make changes to this bug.