Firefox opens with multiple tabs open, new tab selected, open file then one tab request resend info, now can't operate anything

RESOLVED DUPLICATE of bug 476541

Status

()

--
critical
RESOLVED DUPLICATE of bug 476541
9 years ago
7 years ago

People

(Reporter: cleargat, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2

Sorry for the long summary.

This is the sequence of the problem.

I startup Firefox 3.6 and it opens up a window which has many tabs-10 or more. I allow this to proceed for a few seconds. Then I want to open a new tab to open a file (File > Open File) and that happens. I get the File Open dialog box allowing me to select the file.

Then a tab from the Firefox open window requests to "Resend info" which results in two windows requesting attention, and it is not possible to select any of these windows now to select either "Resend info" or "Open" from the Open File dialog box.

In effect I am in a loop situation and I can only get out of it by "Force Quitting" Firefox! A very bad experience indeed.

I have also noticed this problem with earlier versions of Firefox, but I was too lazy to report it!

Reproducible: Always

Steps to Reproduce:
1. I startup Firefox 3.6 and it opens up a window which has many tabs-10 or more.

2. Then I want to open a file (File > Open File) in a new tab and that happens, allowing me to choose a file to open.

3. Then a tab from the Firefox open window (from step 1.) requests to "Resend info" (login to another site.

4. Now "Resend Info" and "Open file" dialog box both request attention and none are able to be handled by keyboard keys or mouse clicking on the highlighted buttons.
Actual Results:  
the program is in a loop which is only exited by "Force Quitting" Firefox!

Expected Results:  
I cannot respond to any request to either "Resend info" or "Open file"

Either "Resend info" window or "File open" window must become the active window so it can receive the mouse or keyboard input
Group: core-security
deadlock on dialogs sounds like a dup
Keywords: hang
Whiteboard: dupme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.