With a form, Option tag with attribute Label is not shown if text between option tags are entered

RESOLVED DUPLICATE of bug 40545

Status

()

defect
RESOLVED DUPLICATE of bug 40545
10 years ago
10 years ago

People

(Reporter: travisnapoleansmith, Unassigned)

Tracking

({html4})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)

When a form is created with xhtml using a option tag with a label, the label is not shown if their is text inside of the option tag.  I am attaching some sample code:
<form>
<select dir="ltr" lang="en-us" tabindex="1" xml:lang="en-us" name="Plattsburgh State Men's Basketball Head Coach Tom Curle">
  <option dir="ltr" lang="en-us" xml:lang="en-us" label="Chicken" selected="selected">
    Computer and Technology
  </option>
 </select>
</form>


computer and technology is displayed instead of Chicken

Reproducible: Always
Labels are suppose to be for short versions of the text. According to W3C Standards a label as an attribute for select is suppose to be shown instead of the text.  IE 8, Opera and Safari all render this properly.
Keywords: html4
Duplicate of Core bug 40545?
It is a duplicate of bug 40545.  Didn't find it when I searched for form option or form label.  This was reported first in 2000.  It should be fixed considering all of the major browsers render the form label properly.  This includes IE 8, IE 7, Safari and Opera.
Product: Firefox → Core
Changed product to core.  Maybe it should also go under FireFox because that is where I searched for the bug because it was happening in FireFox.  I don't used the other Mozilla programs right now!
QA Contact: general → general
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: option-label
You need to log in before you can comment on or make changes to this bug.