undefined? entity error messenger/content/accountcreation/emailWizard.xul acDTD

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: smolejv, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; sl; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 GTB6 (.NET CLR 3.5.30729)
Build Identifier: 305pre shredder

-XMLParsingError = Razčlenitvena napaka v XML: %1$S\nMesto: %2$S\nŠtevilka vrstice: %3$d, stolpec: %4$d\:

instead of 

-XMLParsingError = Razčlenitvena napaka v XML: %1$S\nMesto: %2$S\nŠtevilka vrstice: %3$u, stolpec: %4$u\:

crashes the build (in windows, Unix, OSX)

The error (first reported by Axel) is corrected in the commit to http://hg.mozilla.org/releases/l10n-mozilla-1.9.1/sl, sent 28.03.2010 at 21:00 to sipaq

Reproducible: Sometimes

Steps to Reproduce:
If there's no profile (my assumption) the errors pops up. The build works OK, if an existing profile is found.
(Reporter)

Comment 1

9 years ago
Created attachment 435476 [details]
screenshot with a reported error in the xml parser

The shredder does not exactly crash - but there's no way for a new customer to create an account - any account.

That's serious enough to give the bug the high(est) prio.

Updated

9 years ago
Summary: xmlParsing error crashes the build → undefined? entity error messenger/content/accountcreation/emailWizard.xul acDTD
(Reporter)

Comment 2

9 years ago
error present also in 3.2a1PRE.sl - i.e. the next nightly build - of 29.03.2010

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 435871 [details] [diff] [review]
Proposed fix

Vito, having heard about your problem I took a quick look at it. It turns out the changes in comment 0 won't quite be enough to fix the issue.

The issue is that in accountCreation.dtd the entities called "insecureSelfSigned.description" and "insecureUnencrypted.description" both have incorrect references to "brandShortName".

They are currently written as "& brandShortName;" rather than "&brandShortName". One of the three is also missing the semi-colon.

The patch I'm attaching shows my proposed fix for it, you'll need to get it driven into the repository if you agree it is the right fix. In my tests this got the account wizard working correctly.
(Reporter)

Comment 4

9 years ago
Thanks for the patch file! I looked (and found) some more:

There were 2+1 = 3 ...brandShortName... errors (2 in accountCreation and then one somewhere else with "$ brandShortName"). Given 110+ shortNames in the material 3 errors is reasonable I hope. 

Also a few mixups with ShortName vs FullNama vsa ???NameDA. I corrected them all (plus hunted down some more terminal blanks) and then sent the patch to Simon - I still depend on him for final pushes.

Thanks a lot for a quick reaction - thank God it did not involve maddling with DOM. Anyhow, let's see if this is the end of this story - waiting for the nigthly build.

Regards

Vito
(Reporter)

Comment 5

9 years ago
The medicine worked. The problem is gone in the next nightly build
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.