Closed Bug 555633 Opened 10 years ago Closed 10 years ago

nanojit: rename opcodes in LIRopcode.tbl

Categories

(Core Graveyard :: Nanojit, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: njn, Unassigned)

References

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tamarin, fixed-in-tracemonkey)

Attachments

(2 files, 4 obsolete files)

Attached patch NJ patch (obsolete) — Splinter Review
This patch renames the opcodes in LIRopcode.tbl according the naming scheme
worked out in bug 504506, and creates aliases to all the old names so that no other code need be changed for the moment.

It also adds f64cmp_to_{i,u}32cmp() which TM will use.
Attachment #435530 - Flags: review?(edwsmith)
Attached patch TM patch (obsolete) — Splinter Review
This patch uses the new f64cmp_to_{i,u}32cmp() functions rather than doing a hacky convert-float-cmp-to-integer-cmp-via-subtraction.
Attachment #435531 - Flags: review?(jseward)
Attached patch NJ patch v2 (obsolete) — Splinter Review
It's worth noting that this patch changes the opcode order drastically as well.  But both TM and TR appear to be running fine.
Attachment #435530 - Attachment is obsolete: true
Attachment #435533 - Flags: review?(edwsmith)
Attachment #435530 - Flags: review?(edwsmith)
Blocks: 504506
Comment on attachment 435533 [details] [diff] [review]
NJ patch v2

I reviewed the aliases carefully for typos, but only skimmed the fields in the opcode table.
Attachment #435533 - Flags: review?(edwsmith) → review+
Attachment #435531 - Flags: review?(jseward) → review+
http://hg.mozilla.org/mozilla-central/rev/c7cfe9ef7ba8
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
http://hg.mozilla.org/tamarin-redux/rev/5365c4fddd53
Whiteboard: fixed-in-nanojit, fixed-in-tracemonkey → fixed-in-nanojit, fixed-in-tracemonkey, fixed-in-tamarin
Attached patch rename stb/stw => stl2b/stl2w (obsolete) — Splinter Review
Reopening to consder two changes suggested by Rick:

stb  =>  stl2b     // store long truncated to byte
stw =>  stl2w     // store long truncated to word

the new names reflect the fact that the store value must be an [u]int32 value and gets truncated, mirroring ldb2l and ldw2l
Assignee: nnethercote → edwsmith
Status: RESOLVED → REOPENED
Attachment #439041 - Flags: review?(nnethercote)
Attachment #439041 - Flags: feedback?(rreitmai)
Resolution: FIXED → ---
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: fixed-in-nanojit, fixed-in-tracemonkey, fixed-in-tamarin
Target Milestone: --- → Future
Attachment #439041 - Flags: review?(nnethercote) → review+
Attachment #439041 - Flags: feedback?(rreitmai) → feedback+
http://hg.mozilla.org/tracemonkey/rev/b5ed12eb45b3
Whiteboard: fixed-in-nanojit, fixed-in-tamarin → fixed-in-nanojit, fixed-in-tamarin, fixed-in-tracemonkey
This patch does not add aliases for the intel names that we started using; I will post another patch shortly that fixes LIR.h the rest of the way, plus LIR.cpp and Assembler.cpp/h.
Attachment #435531 - Attachment is obsolete: true
Attachment #435533 - Attachment is obsolete: true
Attachment #439041 - Attachment is obsolete: true
Attachment #440662 - Flags: review?(nnethercote)
(forgot to mention: passed lirasm tests, once the next two patches were applied)
Attachment #440667 - Flags: review?(nnethercote) → review+
Comment on attachment 440662 [details] [diff] [review]
LIRopcodes.tbl and LIR.h: rename intel names to final C-based names

>- * - 's': "single", ie. 32-bit floating point value
>+ * - 'f': "single", ie. 32-bit floating point value

Change "single" to "float".

r=me with that fixed.
Attachment #440662 - Flags: review?(nnethercote) → review+
Assignee: edwsmith → nobody
I'm pretty sure this has been merged into m-c.  Marking as fixed.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.