Closed Bug 555665 Opened 13 years ago Closed 12 years ago

Improve high DPI (increased text size) support

Categories

(Firefox :: Shell Integration, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 537890

People

(Reporter: at.light, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Operating systems allow for increased DPI resolution, which increases the size of text, icons, and most other UI. Firefox currently does not support this. 

Internet Explorer 8 on Windows 7 has been designed to support high DPI scenarios, in ways like:
* all pages zoomed by default in accordance with the OS user preference
* toolbar icons, etc., furnished in larger sizes, so stretching does not occur
* favicons managed so stretching is not required

Firefox does not respond to an abnormal DPI correctly. Setting the layout.css.devPixelsPerPx user preference enlarges the toolbar icons and webpages (but not UI text), but stretching is required. 

This bug is a request for this situation to be improved.

There are other bugs that may be of interest, like bug 433664.

Reproducible: Always
work is being done in bug 537890, bug 549919
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 537890
You need to log in before you can comment on or make changes to this bug.