avoid duplication of entries in autocomplete results

RESOLVED DUPLICATE of bug 564573

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 564573
9 years ago
9 years ago

People

(Reporter: elmar.ludwig, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Since bug 480350 landed, the list of loaded URLs is included in the autocomplete results. URLs which are in history (or bookmarks) and also loaded in a tab show up twice in the autocomplete results. This often causes some duplicated entries in the dropdown (one with the URL, one with "switch to tab") and makes the URL bar harder to use for me: I'm quite used to loading URLs by typing phrases into the location bar and selecting the first/second/third URL in the list. This usage pattern breaks when entries are duplicated in the list, depending on which URLs I have currently open in other tabs (i.e. it is not predictable what the second or third item in the dropdown will be).

Updated

9 years ago
Blocks: 558354
Duping forward since there are more comments over there.
No longer blocks: 558354, 480350
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564573
No longer blocks: 480350
You need to log in before you can comment on or make changes to this bug.