Closed Bug 555719 (SQLite3.6.23.1) Opened 10 years ago Closed 10 years ago

Upgrade to SQLite 3.6.23.1

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a4

People

(Reporter: asuth, Assigned: asuth)

References

Details

We need to upgrade to 3.6.23.1 once it is released.

SQLite 3.6.23 has a regression in its implementation of the FTS3 "offset" function which can potentially result in misleading errors that say "database disk image is malformed".  This problem does not affect anything in-tree, but is upsetting to Thunderbird and maybe some extensions.  SQLite 3.6.23.1 is a special release that has this fix and a few others.

The SQLite folks have provided us with a release candidate and I have successfully run the storage tests as well as the Thunderbird tests that uncovered the bug.  So we should be good to go once 3.6.23.1 gets its official release barring any re-spins that require re-testing on our end.
Alias: SQLite3.6.23.1
pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/a48bb2249b4b
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
since it stuck, pushed configure.in change to comm-central:
http://hg.mozilla.org/comm-central/rev/0b8f82d55a44
Target Milestone: --- → mozilla1.9.3a4
You need to log in before you can comment on or make changes to this bug.