Last Comment Bug 555730 - Make nightly partial updates work for SeaMonkey trunk
: Make nightly partial updates work for SeaMonkey trunk
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Release Engineering (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1a1
Assigned To: Robert Kaiser
:
:
Mentors:
Depends on: 511967 554939 556564
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 09:18 PDT by Robert Kaiser
Modified: 2010-04-07 14:37 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Robert Kaiser 2010-03-29 09:18:01 PDT
Bug 511967 enabled normal build slaves to create partial updates for nightlies, we should get this to work for SeaMonkey as well.

In theory, only attachment 433426 [details] [diff] [review] should still need to be ported, the SeaMonkey-specific code part has been done by bug 554939, attachment 433579 [details] [diff] [review] has updated misc.py for us as well and should theoretically have all the vars set correctly, everything else applies globally anyhow.

If this works out in practice with just those changes will be seen once we put it into production.
Comment 1 Robert Kaiser 2010-03-29 09:41:15 PDT
http://hg.mozilla.org/build/buildbot-configs/rev/fe12ba9f6bfd has done the necessary config changes, http://hg.mozilla.org/build/buildbot-configs/rev/f8619105fe74 was needed to fix up 1.9.1 so checkconfig was satisfied. The master has been reconfigured, we'll see how things turn out when the next nightly cycles run tomorrow.
Comment 2 Robert Kaiser 2010-03-29 12:17:38 PDT
OK, the make upload workdir change in attachment 433579 [details] [diff] [review] did cause some bustage, which I have resolved locally for the moment. If nothing else breaks (esp. on the nightlies), I'll attach that patch to bug 511967 and get it resolved in the original source from there.
Comment 3 Robert Kaiser 2010-03-30 18:15:39 PDT
OK, this all should work now, but I'd like confirmation from actual testing on 2.1a1pre nightlies from yesterday or later - all those should get partials for update now.
Comment 4 Serge Gautherie (:sgautherie) 2010-04-06 11:30:35 PDT
It looks like this could now be enabled for SM 2.0 too, if wanted.
Comment 5 Robert Kaiser 2010-04-06 12:58:22 PDT
We don't have any nightly updates enabled on 2.0.x, and I'm not planning for that, as we might need some more code patches there as well. It's better to put our scarce workforce into making things better for the future.
Comment 6 rsx11m 2010-04-07 14:37:12 PDT
Verified fixed: 2.1a1pre WinXP, 20100402 to 20100406 (complete) followed by 20100406 to 20100407 (partial), works both as intended now.

Note You need to log in before you can comment on or make changes to this bug.