switch theme will damage editing data and others

VERIFIED DUPLICATE of bug 43350

Status

()

P3
normal
VERIFIED DUPLICATE of bug 43350
18 years ago
17 years ago

People

(Reporter: ftang, Assigned: sfraser_bugs)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I think this is a very serious issue.
Use PR3.
1. Open Navigator window
2. Open Composer (or Mail composition)
3. type something
4. go to Navigator window and chagne theme by "View:Apply Theme" to a different one.
Expect result-
The theme will switch and all the content in the html viewing and my editing
document / mail still the same.
actual result-
the theme got switch, the navigator window show blank now. The worst part is all
the document/mail that I am editing is gone... it is also blank.
This is data lostage.

I think we should fix this by rtm, either put an alert box to tell the user that
they better save the data first or fix the real problem.
(Reporter)

Comment 1

18 years ago
suggest for rtm.
Keywords: rtm

Comment 2

18 years ago
isn't this a dup of bug 44437 "Current web page disappears when switching
themes" ?
There are comments there about content in editing fields also vanishing, so the
summary is somewhat misleading. It would seem the whole issue is covered there.

Comment 3

18 years ago
This is a problem with skin switching, related to the editor.  I suspect that 
there is already a bug filed on this issue.  Sending to skinability, for lack of 
a better idea...
Assignee: hangas → ben
Component: Themes → Skinability
QA Contact: pmac → blakeross

Comment 4

18 years ago
Simon, I'm sure this is a dup ...
Assignee: ben → sfraser
Component: Skinability → Editor

Comment 5

18 years ago
Yep, it's a dup.  Of bug #43350.


*** This bug has been marked as a duplicate of 43350 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.