Closed Bug 55580 Opened 19 years ago Closed 18 years ago

ftp: .pdf displays in window

Categories

(Core Graveyard :: File Handling, defect, P3, major)

x86
All

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 109236

People

(Reporter: tever, Assigned: mscott)

References

()

Details

Overview Description:  Not sure if this is an ftp or plug-in problem.  Adobe is 
not launching when downloading pdf files from ftp sites.  

Steps to Reproduce:
1.)  go to the url listed

Actual Results:  browser displays blank screen and often times locks up

Expected Results:  Should open Acrobat reader and display document

Build Date & Platform Bug Found:
WinNT 2000100508

Additional Builds and Platforms Tested On:
works on mac
does not work on linux but could be different problem

Additional information:
Shrir confirmed this is failing on an internal 'slip' ftp site as well.
Confirming this on WindowsNT [build 2000101008]
Did _not_ see the problem on Linux [build 2000100909]
As I mentioned in bug 54393, pdf files over ftp are displayed as text in the
browser window for me rather than being downloaded or viewed with acrobat.
(Linux build 2000110621)
ftp bugs to component:ftp
Assignee: gagan → dougt
Component: Networking → Networking: FTP
Target Milestone: --- → M19
Blocks: 61688
Blocks: 62354
*** Bug 64115 has been marked as a duplicate of this bug. ***
Updating OS/Platform to Reflect bug 64115
OS: Windows NT → All
Scott, per email, I am assigning you my MIME related bugs.  
Assignee: dougt → mscott
Dupe, but see comments I'm about to make in the other bug.

*** This bug has been marked as a duplicate of 54393 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
QA Contact: tever → benc
changed summary ("download" works if you use save as...).

REOPEN: 
until bug 54393 has a clear solution to this problem, I'd like to keep each file 
type independent.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: downloading pdf from ftp site not working → ftp: .pdf displays in window
Ok.  Let's try to get a handle on the exact problem here.

Given an ftp file we can take the following steps to figure out what type it is:

1)  look for extension in helper app prefs (bug 109236, has patch)
2)  look for extension in system mime prefs (should be working on all platforms,
    on windows this would mean the registry)
3)  Use our built-in type list (bug 87403).  pdf is not in this list but could
    be added
4)  Use the unknown content decoder (which then needs to be able to detect PDF. 
    this is not hard -- all pdf files start with %PDF-versionnumber

The original bug is likely a duplicate of bug 109236, based on the description. 
So we could mark this bug duplicate, make it bug cover item 4, or make it cover
adding pdf to the known type list in item 2.  Thoughts?
#4 sounds like a good RFE, no matter what. For #2, I'm not sure what you mean.
Item 4 filed as bug 110662.

Nevermind what I said about Item 2.  I meant Item 3 and fixing Item 4 makes this
whole issue moot anyway.

This bug no longer serves a useful purpose... resolving duplicate of the thing
that was the problem originally

*** This bug has been marked as a duplicate of 109236 ***
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → DUPLICATE
-> file handing
Component: Networking: FTP → File Handling
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.