During test 509749-1.html: automation.py: application timed out after 330 seconds with no output just after NPP_Destroy

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: bas.schouten, Assigned: bent.mozilla)

Tracking

({intermittent-failure})

Trunk
x86
Windows XP
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -, status1.9.2 unaffected)

Details

(Reporter)

Description

9 years ago
There seems to be a new orange since http://hg.mozilla.org/mozilla-central/rev/7f2aff4309a5. It does not seem to be related to that bug.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269917996.1269920114.29345.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/29 19:59:56
s: mw32-ix-slave06
(Reporter)

Comment 1

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269926200.1269928233.14465.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/29 22:16:40
s: mw32-ix-slave06
Based on this starting today and being windows only, these csets seem suspect

http://hg.mozilla.org/mozilla-central/rev/f3569af989e8
http://hg.mozilla.org/mozilla-central/rev/28b6958c2372
http://hg.mozilla.org/mozilla-central/rev/e70cb4e0921a

Apparent randomness is disconcerting.
Summary: automation.py: application timed out after 330 seconds with no output → automation.py: application timed out after 330 seconds with no output just after NPP_Destroy
Summary: automation.py: application timed out after 330 seconds with no output just after NPP_Destroy → During test 509749-1.html: automation.py: application timed out after 330 seconds with no output just after NPP_Destroy
(Reporter)

Comment 3

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269954630.1269956688.16002.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/30 06:10:30
s: mw32-ix-slave12

Comment 4

9 years ago
This must be for the test before 509749 - 505912-1. 509749 doesn't have a plugin in it, 505912-1 uses the test plugin. FWIW, I couldn't reproduce after repeated attempts in a local release build.

http://hg.mozilla.org/mozilla-central/rev/f3569af989e8

^^ Maybe we should start backing out suspect patches, starting with that one?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1269976444.1269978640.12761.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/30 12:14:04
s: mw32-ix-slave09

Updated

9 years ago
Blocks: 478976, 554759
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270001471.1270003559.19201.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/30 19:11:11
s: mw32-ix-slave09

Comment 8

9 years ago
Because this is trunk-only and the regression candidates aren't meant for the branch, I don't think this needs to block lorentz-anything.
No longer blocks: 554759
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270027711.1270029853.27922.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 02:28:31
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270037593.1270039782.1064.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 05:13:13
s: mw32-ix-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270044155.1270046408.22137.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 07:02:35
s: mw32-ix-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270046743.1270048938.30442.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 07:45:43
s: win32-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270054878.1270056961.23803.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 10:01:18
s: win32-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270053775.1270055792.20289.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/03/31 09:42:55
s: mw32-ix-slave03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270166473.1270168665.14930.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/01 17:01:13
s: win32-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270195340.1270197251.15897.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/02 01:02:20
s: win32-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270222859.1270224916.13314.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/02 08:40:59
s: win32-slave24

Comment 18

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270227484.1270229783.28137.gz

WINNT 5.2 mozilla-central debug test crashtest [testfailed] Started 08:40, finished 09:16WINNT 5.2 mozilla-central debug test crashtest [testfailed] Started 08:40, finished 09:16
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270543310.1270545375.21122.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/06 01:41:50
s: mw32-ix-slave12

Comment 20

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270594646.1270597203.6689.gz
WINNT 5.2 mozilla-central debug test crashtest
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270600583.1270602818.22178.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/06 17:36:23
s: mw32-ix-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270673594.1270675694.21859.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/07 13:53:14
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270680021.1270682382.10232.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/07 15:40:21
s: win32-slave36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270677824.1270680551.4474.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/07 15:03:44
s: mw32-ix-slave03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270690655.1270693177.10307.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/07 18:37:35
s: mw32-ix-slave07
(Reporter)

Comment 27

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270714282.1270717802.5840.gz
WINNT 5.2 mozilla-central debug test mochitests-1/5 on 2010/04/08 01:11:22
s: win32-slave26
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270719307.1270722330.23396.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 02:35:07
s: mw32-ix-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270736534.1270738956.29208.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 07:22:14
s: mw32-ix-slave09

Comment 30

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270743978.1270746638.27774.gz#err0
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 09:26:18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270761831.1270764550.20575.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 14:23:51
s: mw32-ix-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270767313.1270769523.3467.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 15:55:13
s: mw32-ix-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270781238.1270783283.7070.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 19:47:18
s: win32-slave36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270787735.1270789730.21801.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/08 21:35:35
s: mw32-ix-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270825120.1270827168.8617.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/09 07:58:40
s: mw32-ix-slave03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270827827.1270829845.16899.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/09 08:43:47
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270856227.1270858311.609.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/09 16:37:07
s: mw32-ix-slave10
(Reporter)

Comment 40

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270946897.1270948965.29550.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/10 17:48:17
s: mw32-ix-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270957310.1270959486.19391.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/10 20:41:50
s: win32-slave01
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1270972610.1270974597.18521.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 00:56:50
s: mw32-ix-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271012462.1271014452.5247.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 12:01:02
s: mw32-ix-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271017020.1271019052.17300.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 13:17:00
s: mw32-ix-slave03

Comment 45

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271018275.1271020370.20546.gz#err0
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 13:37:55
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271028446.1271030437.13431.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 16:27:26
s: win32-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271036162.1271038281.32307.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/11 18:36:02
s: mw32-ix-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271061181.1271063293.5637.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/12 01:33:01
s: mw32-ix-slave16

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271062055.1271064241.9457.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/12 01:47:35
s: win32-slave33
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271110466.1271112866.20706.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/12 15:14:26
s: win32-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271200432.1271202676.6790.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/13 16:13:52
s: mw32-ix-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271267210.1271269217.32190.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/14 10:46:50
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271341812.1271344006.30810.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/15 07:30:12
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271408900.1271411124.5847.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/16 02:08:20
s: mw32-ix-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271427814.1271429825.32620.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/16 07:23:34
s: mw32-ix-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271433210.1271435319.17889.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/16 08:53:30
s: win32-slave41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271435041.1271437186.23544.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/16 09:24:01
s: mw32-ix-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271459017.1271461085.26780.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/16 16:03:37
s: mw32-ix-slave13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271529382.1271531400.20872.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/17 11:36:22
s: mw32-ix-slave09
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271576529.1271578545.1031.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/18 00:42:09
s: mw32-ix-slave06

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271578948.1271581044.8766.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/18 01:22:28
s: win32-slave35

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271601665.1271603881.8871.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/18 07:41:05
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271782736.1271784707.25680.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 09:58:56
s: mw32-ix-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271785565.1271787581.1355.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 10:46:05
s: win32-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271790657.1271792822.16896.gz#err0
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 12:10:57  
s: win32-slave36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271794376.1271796484.27777.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 13:12:56
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271805743.1271807867.29891.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 16:22:23
s: mw32-ix-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271822001.1271824038.4982.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/20 20:53:21
s: mw32-ix-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1271985848.1271987995.2235.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/22 18:24:08  
s: win32-slave41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272027360.1272029337.17892.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/23 05:56:00
s: mw32-ix-slave05
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272034571.1272036566.5702.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/23 07:56:11
s: mw32-ix-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272029574.1272031550.24151.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/04/23 06:32:54
s: mw32-ix-slave19
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272050150.1272052137.17954.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/04/23 12:15:50
s: mw32-ix-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272072716.1272074672.15316.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/23 18:31:56
s: mw32-ix-slave14

Updated

9 years ago
blocking1.9.2: --- → ?
blocking2.0: --- → ?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272144789.1272146763.3056.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/24 14:33:09
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272154149.1272156115.19670.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/24 17:09:09
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272162762.1272164742.2424.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/24 19:32:42
s: mw32-ix-slave10

Since nobody's working on this, and nobody's working on backing out the things that might have caused it, does anyone care if I disable the test that triggers it (assuming comment 4 is right about it being http://mxr.mozilla.org/mozilla-central/source/layout/generic/crashtests/505912-1.html?force=1) on Windows debug?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272202715.1272204707.32245.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/25 06:38:35
s: mw32-ix-slave07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272204170.1272206157.3903.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/25 07:02:50
s: mw32-ix-slave06
I think we should do trial backouts of the patches listed in comment #2. Back each patch out for one day.
Of the three, the first has already been backed out, backing out the second will break the findbar and alltabs panels, and backing out the third will break getpersonas.com. Maybe someone who is awake around nightly-time could back them out after one nightly starts, then reland before the next one starts?

Or, since the current frequency is around one in three, making it pretty easy to reproduce, maybe someone could borrow a slave and test backing them out without using the tinderbox to test?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272237168.1272239221.14164.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/25 16:12:48
s: win32-slave30
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272241584.1272243628.23946.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/25 17:26:24
s: win32-slave36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272296581.1272298627.4729.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 08:43:01
s: win32-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272293442.1272295480.27558.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 07:50:42
s: mw32-ix-slave02
Jesse - you nominated this for blocking; is that because it blocks OOPP?
Jesse - see also comment 8, which indicates that this isn't happening anywhere other than the trunk.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272301106.1272303104.19444.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 09:58:26
s: win32-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272308394.1272310414.10024.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 11:59:54
s: mw32-ix-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272313307.1272315320.26146.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 13:21:47
s: win32-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272313554.1272315765.27399.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 13:25:54
s: win32-slave34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272316265.1272318497.2836.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 14:11:05
s: win32-slave32
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272296605.1272298564.4470.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/04/26 08:43:25
s: mw32-ix-slave22
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272323447.1272325504.25120.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 16:10:47
s: mw32-ix-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272325948.1272328013.389.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 16:52:28
s: win32-slave30

Updated

9 years ago
blocking1.9.2: ? → ---
status1.9.2: --- → unaffected
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272327466.1272329550.4551.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 17:17:46  
s: win32-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272336084.1272338290.27883.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 19:41:24
s: win32-slave39
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272342611.1272344840.15915.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 21:30:11
s: win32-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272342325.1272344463.14464.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/26 21:25:25
s: mw32-ix-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272362247.1272364261.14623.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/27 02:57:27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272375523.1272377669.13883.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/27 06:38:43
s: win32-slave31
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272379169.1272381213.25812.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/27 07:39:29
s: win32-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272428604.1272430728.8770.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/27 21:23:24
s: win32-slave41
See comment 81 and comment 82. (And "becoming pretty frequent" is pretty funny.)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272463095.1272465297.11150.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 06:58:15
s: win32-slave39

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272456882.1272458919.19154.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 05:14:42
s: win32-slave27
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272466769.1272469253.22915.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 07:59:29
s: win32-slave11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272480219.1272482254.1076.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 11:43:39
s: win32-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272483537.1272485586.13595.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 12:38:57
s: win32-slave16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272498597.1272500596.29090.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 16:49:57
s: mw32-ix-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272508581.1272510666.23700.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/28 19:36:21
s: mw32-ix-slave02
philor beat me to that one.

I just reproduced a similar-looking assertion locally in the plugin subprocess.  bent and I are looking into it.  This may be a combination of a bad assertion and an incorrectly configured subprocess (not honoring XRE_NO_WINDOWS_CRASH_DIALOG), which might explain the hang (crash dialog?).
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272532738.1272534927.27727.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/29 02:18:58
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272553518.1272555543.15623.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/29 08:05:18
s: mw32-ix-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272670089.1272672186.24565.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/04/30 16:28:09
s: mw32-ix-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272717238.1272719272.32119.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/01 05:33:58
s: mw32-ix-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272783125.1272785144.19358.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/01 23:52:05
s: mw32-ix-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272832850.1272834816.11927.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/02 13:40:50
s: mw32-ix-slave05

Comment 124

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272895490.1272897496.19751.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/03 07:04:50
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272908681.1272910677.23136.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/05/03 10:44:41
s: mw32-ix-slave23
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272942243.1272944250.23694.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/05/03 20:04:03
s: mw32-ix-slave22
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1272984775.1272986802.30270.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/04 07:52:55
s: mw32-ix-slave02
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1272995877.1272998234.1224.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/05/04 10:57:57
s: mw32-ix-slave18

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1273022200.1273024161.28111.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/05/04 18:16:40
s: mw32-ix-slave18

http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1273024998.1273027052.2139.gz
WINNT 5.2 tracemonkey debug test crashtest on 2010/05/04 19:03:18
s: mw32-ix-slave25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273087210.1273089328.3052.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/05 12:20:10
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273126857.1273128869.25449.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/05 23:20:57
s: mw32-ix-slave04
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273167274.1273169359.32460.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/06 10:34:34
s: mw32-ix-slave05
(Reporter)

Comment 134

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273177186.1273179258.7650.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/06 13:19:46
s: mw32-ix-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273184657.1273186646.9095.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/06 15:24:17
s: mw32-ix-slave12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273191723.1273193710.6824.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/06 17:22:03
s: mw32-ix-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273260986.1273263002.5350.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/07 12:36:26
s: mw32-ix-slave03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273369342.1273371334.5223.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/08 18:42:22
]s: mw32-ix-slave03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273524105.1273526178.25970.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/10 13:41:45
s: mw32-ix-slave05
(Reporter)

Comment 140

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273536997.1273538994.7232.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/10 17:16:37
s: mw32-ix-slave06
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273543434.1273545489.28790.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/10 19:03:54
s: mw32-ix-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1273561613.1273563615.28943.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/05/11 00:06:53
s: mw32-ix-slave06
Ben says he can have a look at this sometime soonish.
Assignee: nobody → bent.mozilla
Not blocking unless we get reports of this showing up in the wild.
blocking2.0: ? → -
Given the former frequency, I'd say the only thing left to do is figure out what unlikely thing among the stuff that landed in the day or two after comment 142 (or, harder to spot, what buildbot change) accidentally fixed it.

Updated

9 years ago
Blocks: 438871
Comment hidden (Treeherder Robot)

Comment 147

8 years ago
Given comment 145, this sounds like WFM.  I don't see what comment 146 has to do with this bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.