Firefox is redirecting to a common url for all request

RESOLVED FIXED

Status

()

Firefox
Address Bar
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: kskuppu, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1042 Safari/532.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Bad Example :http://www.google.com
If you enter any url that starts with :http:// it is redirecting to 

http://en.wikipedia.org/wiki/Hypertext_Transfer_Protocol



Reproducible: Always

Steps to Reproduce:
1. Enter any url prefixed with ":"
2.
3.


Expected Results:  
Instead of the actual site it is loading a common page from wikipedia
actually that is the first google result for "http" search
(Reporter)

Comment 2

8 years ago
Thats true. But is this the expected outcome from the user's point of view? From the end-user perspective it would be better if the ":" is simply omitted and the actual site gets loaded. Does this makes sense?

Updated

8 years ago
Version: unspecified → 3.6 Branch
I think this is now fixed, since bug 565966 disabled the "I'm feeling lucky" functionality in Firefox 4.0, exactly to avoid these surprising events.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Depends on: 565966
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.