Closed Bug 556332 Opened 10 years ago Closed 9 years ago

AVG Toolbar causes Firefox 3.6.2 to leak memory (and maybe use large amounts of CPU)

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: cww, Assigned: greg.mosher)

Details

(Keywords: common-issue+, regression)

From a report on the support forum: https://support.mozilla.com/en-US/forum/1/633202 and http://support.mozilla.com/nl/forum/1/632193

Firefox 3.6.2 with AVG on windows seems to spike CPU usage and cause Firefox to use increasingly more RAM.  It maybe related to form filling.  From the above reports, a number of people say that after disabling AVG, it gets much better.
will do a check for leaks here
Could that be the cause that a lot of users are complaining about high cpu load when opening flash based web pages? We got a couple of reports already.
(In reply to comment #2)
> Could that be the cause that a lot of users are complaining about high cpu load
> when opening flash based web pages? We got a couple of reports already.

If that is the case I got one report from a user on IRC that Fx3.6 is working fine and no high cpu load happens when opening flash content containing web page. It starts with Fx3.6.2 but only in normal mode. In Safe Mode with AVG disabled it's fine too. So we would have a change for 3.6.2 which regressed it on mozilla1.9.2?

Just in case adding regression keywords.
Dozens of reports on SUMO this week.  AVG is present in about 90% of reports.  Many confirmations that disabling AVG toolbar/extensions helps in those cases.  Also reports of other extensions and or Java Console being the culprit but the 90% case is definitely AVG.
Keywords: common-issue+
Do we know what version of AVG this is happening with?
Horray for about:support:

AVG Safe Search
9.0.0.783
true
{3f963a5b-e555-4543-90e2-c3908898db71}

AVG Security Toolbar
4.002.023.004
true
avg@igeared
This has been replicated by AVG support and confirmed to be a problem in the AVG Security Toolbar.  This is a high priority bug internally for AVG and is assigned to the iGeared team.  Fix ETA will be provided once analysis is complete.
Hi Greg, Thanks for the fast response.
No more updates, will check with the iGeared team.
Assignee: nobody → greg.mosher
Status: NEW → ASSIGNED
What is the Status here?
Is a Regression Window still wanted?
Seems to be a confirmed problem with AVG's product, so not sure a regression window is needed anymore. Removing keyword.
This was resolved in the AVG toolbar versions 4.1 and later.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.