Last Comment Bug 556573 - OpenGL video support doesn't support non-multiple-of-4 widths/heights
: OpenGL video support doesn't support non-multiple-of-4 widths/heights
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Bas Schouten (:bas.schouten)
:
Mentors:
http://imagebin.ca/view/gVqPjt.html
: 556356 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-01 11:47 PDT by Joe Drew (not getting mail)
Modified: 2011-04-14 15:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use GL_UNPACK_ALIGNMENT instead of ROW_LENGTH (3.05 KB, patch)
2010-04-01 12:13 PDT, Bas Schouten (:bas.schouten)
joe: review+
Details | Diff | Review

Description Joe Drew (not getting mail) 2010-04-01 11:47:59 PDT
Playing the Big Buck Bunny 480p video results in the linked image's results when we switch to fullscreen OpenGL video. We're just off by a couple of pixels here because the image isn't a multiple of four.
Comment 1 Bas Schouten (:bas.schouten) 2010-04-01 12:13:04 PDT
Created attachment 436536 [details] [diff] [review]
Use GL_UNPACK_ALIGNMENT instead of ROW_LENGTH

We now look for the optimal alignment we've got. And then use GL_UNPACK_ALIGNMENT, in theory this should also work on OGL ES unlike the ROW_LENGTH approach.
Comment 2 Joe Drew (not getting mail) 2010-04-01 12:34:27 PDT
Comment on attachment 436536 [details] [diff] [review]
Use GL_UNPACK_ALIGNMENT instead of ROW_LENGTH

Add comments saying what textures' alignments are being set at each PixelStore call, and one saying "restore to default" at the bottom of the function?
Comment 3 Matthew Gregan [:kinetik] 2010-04-01 12:34:54 PDT
*** Bug 556356 has been marked as a duplicate of this bug. ***
Comment 4 Bas Schouten (:bas.schouten) 2010-04-01 14:22:41 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/3bce11a17af7.

Note You need to log in before you can comment on or make changes to this bug.