lockPref("browser.formfill.enable", false); does not disable "Remember search and form history" item

RESOLVED DUPLICATE of bug 548815

Status

()

Firefox
Preferences
--
major
RESOLVED DUPLICATE of bug 548815
8 years ago
8 years ago

People

(Reporter: Ilanio Castro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

If you create a CFG file with lockPref("browser.formfill.enable", false); the item "Remember search and form history" does not disable.

If you change histroy options to "Remember history" and the change it to "Use custom settings" the item "Remember search and form history" will appear enabled and allow user to check it.

Reproducible: Always

Steps to Reproduce:
1. Create a lockdown CFG file with lockPref("browser.formfill.enable", false); option and modify all.js to call this file.

2. Click on the "Tools" option from menu and choose "Options".

3. On the options window go to "Privacy".

4. On the history options select "Firefox will: Remember history".

5. Now, on the history options select "Firefox will: Use custom settings".

6. Note the item "Remember search and form history" will be enabled, allowing user check it.

7. Note after mouse click on this item it will be disabled, but if you repeat these steps it will show enabled again.
Actual Results:  
The item is enabled.

Expected Results:  
The item have to stay disabled all the time.

I think this is a problem in content\browser\preferences\privacy.js of browser.jar since it does not verify if the "Remember search and form history" ("rememberForms" in the js file) needs to stay disabled before enable it when user changes the history options select control.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548815
You need to log in before you can comment on or make changes to this bug.