Thunderbird cannot be updated by another admin user who didn't install it. Group permission needs fix.

RESOLVED DUPLICATE of bug 394984

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 394984
8 years ago
8 years ago

People

(Reporter: KUROSAKA Teruhiko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

I have multiple users with admin credential in my machine.  I installed Thunderbird as a user called admin1.  There is another user admin2, which I normally use the machine and Thunderbird under.  Thunderbird warned me that there is an update but it cannot update itself because admin2 does not have enough privilege to do so.  The "Check for Update" under Help menu is grayed out.

The file listing shows that all files under /Application/Thunderbird.app are owned by admin1 and group "admin", and only the user "admin1", not group "admin", has write permission. I suspect this is the reason Thunderbird determined that admin2 cannot update itself.

$ ls -ls Thunderbird.app/*
total 16
8 -rw-r--r--    1 admin1  admin  2996  1 11 11:47 Info.plist
0 drwxr-xr-x    3 admin1  admin   102  1 11 11:37 Library
0 drwxr-xr-x   45 admin1  admin  1530  4  2 17:55 MacOS
8 -rw-r--r--    1 admin1  admin     8  1 11 11:47 PkgInfo
0 drwxr-xr-x    3 admin1  admin   102  1 11 11:37 Plug-Ins
0 drwxr-xr-x    4 admin1  admin   136  1 11 11:47 Resources

If I chown all files to admin2, then "Check for Update" is not grayed out and I could update Thunderbird as admin2.  

Reproducible: Always

Steps to Reproduce:
1.Create two user account with administrator privilege
2.Log in as one admin user and install TB of a version that is not latest.
3.Log in as another admin user, start TB, see Help menu.
Actual Results:  
"Check for Update" item is grayed out.


Expected Results:  
"Check for Update" item is shown normal (not grayed out), and choosing that will start updating process.
Exactly the same for Firefox, therefore moving this to toolkit as its a core bug.
Component: Installer → Application Update
Product: Thunderbird → Toolkit
QA Contact: installer → application.update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394984
You need to log in before you can comment on or make changes to this bug.