Last Comment Bug 557197 - [HTML5] 
 in element content expands to CR and CRLF in the DOM shows up as a non-collapsing space in layout
: [HTML5] 
 in element content expands to CR and CRLF in the DOM shows up a...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: x86 Windows Vista
: P2 normal (vote)
: ---
Assigned To: Henri Sivonen (:hsivonen)
:
Mentors:
http://forum.viva.nl/forum/list_messa...
Depends on: 534071
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-05 06:55 PDT by Ria Klaassen (not reading all bugmail)
Modified: 2010-06-24 05:55 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
Minimized test case (13 bytes, text/html)
2010-04-12 00:30 PDT, Henri Sivonen (:hsivonen)
no flags Details

Description Ria Klaassen (not reading all bugmail) 2010-04-05 06:55:59 PDT
STR:

- Set html5.enable to true
- Go to URL

The first line of every comment is aligned correctly to the left, but not the next new lines.

Works: ac1df371f376
Fails: d91d66514c2f
Comment 1 Ria Klaassen (not reading all bugmail) 2010-04-05 06:58:36 PDT
Query: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ac1df371f376&tochange=d91d66514c2f
Comment 2 Henri Sivonen (:hsivonen) 2010-04-08 05:03:16 PDT
This is a regression from bug 546641.

Not sure yet what to do. Options:
 * WONTFIX
 * Revert bug 546641
 * Expand 
 differently in element content and in attribute values.
Comment 3 Henri Sivonen (:hsivonen) 2010-04-08 05:06:10 PDT
Oh, and there's the option of changing how layout deals with CR.

Note: If anyone is searching for duplicates before filing a bug due to seeing this problem on another site, please add a comment with the URL of that site here.
Comment 4 :Ms2ger 2010-04-08 06:58:55 PDT
(In reply to comment #3)
> Oh, and there's the option of changing how layout deals with CR.

Bug 534071?
Comment 5 Henri Sivonen (:hsivonen) 2010-04-08 08:36:19 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > Oh, and there's the option of changing how layout deals with CR.
> 
> Bug 534071?

Looks like it. Good to see it's already on file.
Comment 6 Henri Sivonen (:hsivonen) 2010-04-12 00:30:14 PDT
Created attachment 438430 [details]
Minimized test case

Curiously, the problem occurs when there's a CRLF in the DOM. A CR alone doesn't render as a space.
Comment 7 Henri Sivonen (:hsivonen) 2010-05-26 01:53:05 PDT
Do the drivers consider this to be a 1.9.3 blocker? (Making this bug a blocker effectively means making the dependency bug 534071 a blocker.)
Comment 8 Johnny Stenback (:jst, jst@mozilla.com) 2010-05-26 16:15:14 PDT
We do consider this a blocker (since it's a regression).
Comment 9 Henri Sivonen (:hsivonen) 2010-06-24 05:55:16 PDT
Fixed by the landing of the dependency.

Note You need to log in before you can comment on or make changes to this bug.