Accessing the nav-bar via getElementById during startup removes user buttons

RESOLVED DUPLICATE of bug 554279

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 554279
8 years ago
8 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
This one is really really strange. Basically if you do:

    document.getElementById("nav-bar");


during startup, buttons disappear.

To recreate.

Customize your toolbar by adding a few buttons.

Install the attached extension (all it does is the referenced document.getELementById)

restart

Notice your buttons are gone. 

Go to extension manager.

Disable the extension.

restart

buttons come back
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554279
You need to log in before you can comment on or make changes to this bug.