Click modifiers are broken on switch to tab

VERIFIED WORKSFORME

Status

()

Firefox
Address Bar
VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: eyal gruss (eyaler), Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [switch-to-tab])

(Reporter)

Description

8 years ago
the modifiers ctrl/shift/alt/middle click are broken on the new switch to tab dropdown action

ctrl/middle click gives the error: "Firefox doesn't know how to open this address, because the protocol (moz-action) isn't associated with any program.". it opens a new empty tab (with a bad title) and does not clear the url bar on the original tab as it would normally do

shift-click opens a new window with an empty tab

alt-click offers to save something unclear

we should decide how to map these actions or just block them

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a4pre) Gecko/20100406 Minefield/3.7a4pre (.NET CLR 3.5.30729)
(Reporter)

Updated

8 years ago
Depends on: 480350
Blocks: 480350
Depends on: 556061
No longer depends on: 480350

Comment 1

8 years ago
Cannot confirm on
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100511 Minefield/3.7a5pre (.NET CLR 3.5.30729)

Open in new tab via mmb or ctrl works fine. (Didn't test the other one's, 'cause I don't know what they actually should do.)

Comment 2

8 years ago
This works for me on today's nightly.  Can you reproduce on the 20100628 nightly or later?  (Also, comment 0 mentions mouse click modifiers (as opposed to Enter key modifiers, which is bug 571672), so I clarified the bug title.)
Summary: modifiers are broken on switch to tab → Click modifiers are broken on switch to tab
(Reporter)

Comment 3

8 years ago
further research has revealed that the culprit is in the "Stay-Open Menu" add-on.
i am closing this bug and will notify the add-on creator.
sorry for wasting your time.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [switch-to-tab]
Status: RESOLVED → VERIFIED
(In reply to comment #3)
> further research has revealed that the culprit is in the "Stay-Open Menu"
> add-on.
> i am closing this bug and will notify the add-on creator.
> sorry for wasting your time.

Thanks for confirming this works with the add-on removed and taking the step to notify the add-on developer.
You need to log in before you can comment on or make changes to this bug.