have puppet/opsi ensure talos boxes are using correct time on reboot

RESOLVED DUPLICATE of bug 646056

Status

Release Engineering
General
P3
normal
RESOLVED DUPLICATE of bug 646056
8 years ago
4 years ago

People

(Reporter: alice, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos][puppet][opsi])

(Reporter)

Description

8 years ago
Seem to be having issues (especially with fed64) with talos slaves having really weird dates.  We want to force a time sync on reboot so that we can be sure that dates on talos boxes can be trusted.

Comment 1

8 years ago
For reference see bug 556179.
Looks like |ntpd -q| works on snow leopard... set the time, then quit.
I think I'm using openntpd -S on the n810s.
Not sure what works on windows.
Priority: -- → P3
See also bug 561442. Do we need both ?
(Reporter)

Updated

8 years ago
Whiteboard: [talos]

Updated

8 years ago
Whiteboard: [talos] → [talos][puppet][opsi]
Has this still been a problem?  I think John's work in 561442 should clean this up, and the machines are all running ntpdate on startup as well.
(Reporter)

Comment 5

7 years ago
Well, it could matter for those machines currently outside the releng network (like the tools machines...)
It could, but *has* it mattered?  It looks like we've fixed this two ways, one of which should affect non-releng buildslaves (running ntpdate at startup).

If there's more to do, let's get down to brass tacks: which distro(s) and which environments?
(Reporter)

Comment 7

7 years ago
Tools slaves have not been updated, so that would be tools-r3-fed001/002, tools-r3-fed64-001/002.
bug 646056 got all of our machines using an internal NTP server. I'm pretty sure that makes this bug a dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646056
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.