Class should be different for each type of Mozilla window

VERIFIED DUPLICATE of bug 29856

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 29856
17 years ago
17 years ago

People

(Reporter: ltskinol, Assigned: Dan M)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
20000100806/Linux.

I use FVWM2 as my window manager, which allows me to set per-window
resources, assuming there is a way to distinguish between window types.
I can do this with Netscape, as different windows have different
"Class" and "Resource" values.  For example, I can do things to the
Netscape find and error windows with a line like this:

Style "*_popup" StaysOnTop

With Mozilla, all of the windows (main, find, open location) have a
"Class" and "Resource ID" of "Mozilla-bin".  Could this be changed
to something unique?

Comment 1

17 years ago
over to toolkit.
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → jrgm

Comment 2

17 years ago
I'm clarifying the summary & marking NEW, but that sounds an awful lot like
Motif-type stuff. 
Severity: normal → minor
Summary: Window class always Mozilla-bin → Class should be different for each type of Mozilla window

Comment 3

17 years ago
->danm/future
Assignee: trudelle → danm
Target Milestone: --- → Future

Comment 4

17 years ago
It is not a motif feature. Quite a few window managers allow this, for instance
to keep an app on one workspace.

That doesn't work with mozilla. It does work with for instance GNOME apps.

Confirmed Linux 2000110206
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

17 years ago
dup of bug 29856 "*nix only : Window Class the same for all mozilla windows"

*** This bug has been marked as a duplicate of 29856 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.