All users were logged out of Bugzilla on October 13th, 2018

Context menu in Tabs from Other Computers page should be disabled outside of relevant items

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
9 years ago
21 days ago

People

(Reporter: tracy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [weave1.2b4])

(Reporter)

Description

9 years ago
Seen on about:weave-tabs page

STR:

1) Click History > Tabs from Other Computers
2) Context click on the page content anywhere away from actual tab item or tab group header

Tested results:
the tab item context menu appears (its selections do nothing here)

Expected results:
nothing on context click or perhaps the normal context menu for a web page?
(Reporter)

Updated

9 years ago
Whiteboard: [weave1.2b4]

Comment 1

9 years ago
Similar issue if you select an item and deselect it (cmd-click) then open the context menu.
This was intentional, as there are no borders to indicate what is/isn't part of the UI.  If nothing is selected, it should only show "Refresh List" (the separator shows as well, but that's a bug), and if items are selected they should work properly.  The wording isn't as good as it should be (i.e. "Open Selected Tab" instead of "Open This Tab") but I don't see why we would try to arbitrarily limit where the user can right click.
WONTFIXing per rationale in comment 2
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

8 years ago
Duplicate of this bug: 597429
(Assignee)

Updated

21 days ago
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.