Last Comment Bug 557896 - Display OpenGL info on error console
: Display OpenGL info on error console
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Bas Schouten (:bas.schouten)
:
Mentors:
: 556325 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-07 13:39 PDT by Bas Schouten (:bas.schouten)
Modified: 2013-02-07 01:22 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Display info for OpenGL usage (1.60 KB, patch)
2010-04-07 13:39 PDT, Bas Schouten (:bas.schouten)
no flags Details | Diff | Splinter Review
Display info for OpenGL usage v2 (1.61 KB, patch)
2010-04-07 14:19 PDT, Bas Schouten (:bas.schouten)
joe: review+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2010-04-07 13:39:07 PDT
Created attachment 437652 [details] [diff] [review]
Display info for OpenGL usage

For the time being we don't have about:gfx yet. We should display some info on the error console indicating when the OpenGL layer manager is being initialized succesfully, and some data about what OpenGL version is being used to assist in debugging issues.

The attached patch gives some information, for example on my laptop it outputs:

OpenGL LayerManager Initialized Succesfully.
Version: 3.0.0
Vendor: NVIDIA Corporation
Renderer: GeForce GT 230M/PCI/SSE2
Comment 1 Bas Schouten (:bas.schouten) 2010-04-07 14:19:58 PDT
Created attachment 437662 [details] [diff] [review]
Display info for OpenGL usage v2

Hopefully this improves string usage.
Comment 2 Joe Drew (not getting mail) 2010-04-07 14:26:50 PDT
Comment on attachment 437662 [details] [diff] [review]
Display info for OpenGL usage v2


>+    console->LogStringMessage(msg.BeginReading());

I think that you should just use .get() here.

r=me otherwise!
Comment 3 Mike Shaver (:shaver -- probably not reading bugmail closely) 2010-04-08 04:40:45 PDT
Hey! I filed this as 556325! Do you hate me?
Comment 4 Mike Shaver (:shaver -- probably not reading bugmail closely) 2010-04-08 04:41:10 PDT
*** Bug 556325 has been marked as a duplicate of this bug. ***
Comment 5 Joe Drew (not getting mail) 2010-04-08 07:43:14 PDT
(In reply to comment #3)
> Hey! I filed this as 556325! Do you hate me?

You already know the answer to that!
Comment 6 Bas Schouten (:bas.schouten) 2010-04-08 10:30:35 PDT
(In reply to comment #3)
> Hey! I filed this as 556325! Do you hate me?

:(
I wasn't on the CC list nor the assignee. I simply missed it.
Comment 7 Matt Woodrow (:mattwoodrow) 2011-10-06 17:51:34 PDT
http://hg.mozilla.org/mozilla-central/rev/dae132705f35
Comment 8 Florian Quèze [:florian] [:flo] 2013-02-07 01:22:46 PST
(In reply to Bas Schouten (:bas.schouten) from comment #0)
> Created attachment 437652 [details] [diff] [review]
> Display info for OpenGL usage
> 
> For the time being we don't have about:gfx yet. We should display some info
> on the error console

Can we remove this now that there's a "Graphics" section (added by bug 586046?) in about:support?
Having this message displayed in the Error Console each time a window is opened is noisy.

Note You need to log in before you can comment on or make changes to this bug.