RTL horizontal scrollbar bad default position

RESOLVED FIXED

Status

()

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: emmanuel, Assigned: smontagu)

Tracking

unspecified
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

With the following code, the richlistbox horizontal scrollbar is
still ltr (left positioned per default) although it should be right positioned.

<?xml version="1.0" encoding="UTF-8" ?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>
<window xmlns:html="http://www.w3.org/1999/xhtml"
xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" dir="rtl">

<hbox flex="1" style="direction: rtl;">
<richlistbox style="width: 100px; direction: rtl;">
<item>this is a really really really really long test sentence.</item>
</richlistbox>
<splitter/>
<browser flex="1" src="" type="content-primary"/>
</hbox>

</window>

Reproducible: Always

Steps to Reproduce:
1. Cut&paste the give XUL code in a file.
2. Open it with FF (for example)
3. Play with the splitter
Actual Results:  
Richlistbox horizontal scrollbar is left positioned.

Expected Results:  
Richlistbox horizontal scrollbar right positioned.
(Assignee)

Updated

8 years ago
Depends on: 508816
(Assignee)

Comment 1

8 years ago
Fixed by bug 508816. Ehsan, do you think this is covered by the existing tests, or does it need its own testcase?
Assignee: nobody → smontagu
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 2

8 years ago
(In reply to comment #1)
> Fixed by bug 508816. Ehsan, do you think this is covered by the existing tests,
> or does it need its own testcase?

Let's get a specific test for this, since otherwise we'd be relying on implementation details...

Do you want me to write the test?
Flags: in-testsuite?
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> Do you want me to write the test?

That would be awesome :)

Comment 4

8 years ago
Created attachment 510795 [details] [diff] [review]
Test case
Attachment #510795 - Flags: review?(smontagu)
(Assignee)

Comment 5

8 years ago
Comment on attachment 510795 [details] [diff] [review]
Test case

smart move removing the "." from the <item> text to ensure that the test fails without bug 508816.
Attachment #510795 - Flags: review?(smontagu) → review+

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/5d3102a24ad1
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.