maemo repacks need to sb-conf select

RESOLVED FIXED

Status

Release Engineering
General
--
critical
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: aki, Assigned: aki)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
Now that Maemo5 builds are doing an |sb-conf select FREMANTLE_ARMEL| in scratchbox, repacks may behave badly and/or break.

Let's do this in a two step manner: this bug will cover running sb-conf select CHINOOK-ARMEL-2007 in maemo repacks.  We'll fix whatever's broken in the FREMANTLE_ARMEL target when we enable l10n repacks for Maemo5.
(Assignee)

Comment 1

8 years ago
Created attachment 437923 [details] [diff] [review]
add sb_target to l10n repack configs

passes checkconfig. patch 1/2
(Assignee)

Comment 2

8 years ago
Created attachment 437924 [details] [diff] [review]
factory update -- add sb_target + sb-conf select steps

Passes checkconfig.

Sadly, I can't insert steps before BaseRepackFactory.__init__(), which creates the full repack steps (and initializes the self.steps variable itself).

I chose to overload preClean() which isn't great.
Pushing two new steps into the front of self.steps is another approach... dunno which is uglier.

Pretty sure this will work, but I'll need to either land this or get a staging env to test.
(Assignee)

Comment 3

8 years ago
Comment on attachment 437923 [details] [diff] [review]
add sb_target to l10n repack configs

This should fix it.
Attachment #437923 - Flags: review?(ccooper)
(Assignee)

Updated

8 years ago
Attachment #437924 - Flags: review?(ccooper)
(Assignee)

Comment 4

8 years ago
Comment on attachment 437923 [details] [diff] [review]
add sb_target to l10n repack configs

This is totally the wrong patch.
Attachment #437923 - Attachment is obsolete: true
Attachment #437923 - Flags: review?(ccooper)
(Assignee)

Comment 5

8 years ago
Created attachment 438009 [details] [diff] [review]
this is the right configs patch
Attachment #438009 - Flags: review?(ccooper)
(Assignee)

Comment 6

8 years ago
Comment on attachment 437924 [details] [diff] [review]
factory update -- add sb_target + sb-conf select steps

Looks like I removed some trailing spaces too, hope those aren't confusing.  I should just file a whitespace bug and be done with it at some point.

Comment 7

8 years ago
Comment on attachment 437924 [details] [diff] [review]
factory update -- add sb_target + sb-conf select steps

Meh, don't beat yourself up too much about overriding preClean. I think it works quite well.
Attachment #437924 - Flags: review?(ccooper) → review+

Updated

8 years ago
Attachment #438009 - Flags: review?(ccooper) → review+
(Assignee)

Comment 8

8 years ago
Comment on attachment 438009 [details] [diff] [review]
this is the right configs patch

http://hg.mozilla.org/build/buildbot-configs/rev/4ebed3f2e189
Attachment #438009 - Flags: checked-in+
(Assignee)

Comment 9

8 years ago
Comment on attachment 437924 [details] [diff] [review]
factory update -- add sb_target + sb-conf select steps

http://hg.mozilla.org/build/buildbotcustom/rev/f787ab82a76b
Attachment #437924 - Flags: checked-in+
(Assignee)

Comment 10

8 years ago
Crossing fingers for working repacks.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.