Closed Bug 558258 Opened 10 years ago Closed 10 years ago

Mac OS X optimized unit tests not being run

Categories

(Release Engineering :: General, defect, blocker)

x86
macOS
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dbaron, Assigned: bhearsum)

References

Details

We seem to have stopped running optimized unit tests on Mac OS X (10.5) sometime yesterday evening.  The last push on which they were run was http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=a1d1e59ac1de .

(There some mostly-failed runs of 10.6 optimized and debug unit tests since then; might that be related to why they disappeared?)
mozilla-central and firefox3.6 trees are closed (been so long since I looked at firefox3.5 and there are so few pushes, I couldn't really tell what it might be missing or not missing).
I assume this is related to the switch to running unittests-on-Talos. bug 548768 was intended to stop running unit tests on the build slaves, and instead run them on Talos machines.
Depends on: 548768
Looking into it.
Assignee: nobody → armenzg
Status: NEW → ASSIGNED
Regression from bug 549427, actually.
Depends on: 549427
No longer depends on: 548768
Blocks: 549427
No longer depends on: 549427
We are looking into this with Ted and we believe that we found the
changeset that causes this:
http://hg.mozilla.org/mozilla-central/rev/1b2e5a9c5214
The problem is that packaged tests were not being uploaded.
As soon as we land it I will trigger a build to see if it gets fixed.
Assignee: armenzg → nobody
No longer blocks: 549427
Status: ASSIGNED → NEW
Depends on: 548768
bhearsum pushed to m-c:
 http://hg.mozilla.org/mozilla-central/rev/cdb18820629c

Armen: you can flip this to VERIFIED once you're satisfied that tests are being uploaded and run again.
Assignee: nobody → bhearsum
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I can now see the test being uploaded and I see it on ftp.
The opt unit test builders are now running again.
I also see it on tinderbox and TBPL.

Thanks guys!
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.