Closed Bug 558265 Opened 10 years ago Closed 10 years ago

Rename {GET,CALL}DSLOT

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: njn, Assigned: njn)

References

Details

Brendan suggests {GET,CALL}FLATUPVAR as the new names.
This should also make any necessary changes so that these ops don't punch through the dslots encapsulation.
Bug 558451 renamed these to {GET,CALL}FCSLOT.  Now I just need address comment 1.
Comment 1 was addressed by the patch queue for bug 558451:

BEGIN_CASE(JSOP_GETFCSLOT)
BEGIN_CASE(JSOP_CALLFCSLOT)
{
    JS_ASSERT(fp->argv);
    uintN index = GET_UINT16(regs.pc);
    JSObject *obj = &fp->argv[-2].toObject();

    JS_ASSERT(index < obj->getFunctionPrivate()->u.i.nupvars);
    PUSH_COPY(obj->getFlatClosureUpvar(index));
    if (op == JSOP_CALLFCSLOT)
        PUSH_NULL();
}
END_CASE(JSOP_GETFCSLOT)

/be
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.