[Debug Firefox 3.7] fails to start on Win2K: "RtlCaptureStackBackTrace not found in KERNEL32.dll"

RESOLVED WONTFIX

Status

()

defect
--
blocker
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

[Don't start :-(] (mozilla-central-win32-debug/1270891739)

I downloaded this build to check bug 557060,
and discovered this error.

Mxr doesn't find RtlCaptureStackBackTrace in the source...
Reporter

Comment 1

9 years ago
Fwiw,
[SeaMonkey 2.1] (comm-central-trunk-win32-debug/1270896370)
doesn't have this bug.
Product: Core → Firefox
QA Contact: general → general
RtlCaptureStackBackTrace is an internal kernel symbol which is exposed as CaptureStackBackTrace.  This is used in the imported chromium code.  I don't see any immediate reason why this wouldn't happen on 1.9.2 either ...

http://mxr.mozilla.org/mozilla-central/source/ipc/chromium/src/base/debug_util_win.cc#262
blocking1.9.2: --- → ?
Component: General → IPC
Product: Firefox → Core
QA Contact: general → ipc
Reporter

Comment 3

9 years ago
(In reply to comment #2)
> I don't see any immediate reason why this wouldn't happen on 1.9.2 either ...

I didn't check m-1.9.2...
Reporter

Comment 4

9 years ago
(In reply to comment #2)

Ah! Duplicate of bug 555485 then :->
Status: NEW → RESOLVED
blocking1.9.2: ? → ---
blocking2.0: ? → ---
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 555485
Reporter

Comment 5

9 years ago
Ftr, bug 555485 comment 7:
{
Benjamin Smedberg [:bsmedberg]      2010-09-23 07:24:41 PDT

We do not intend to make debug builds work on win2k.
}
Depends on: 555485
Resolution: DUPLICATE → WONTFIX
Reporter

Updated

8 years ago
Depends on: 699247
You need to log in before you can comment on or make changes to this bug.