The default bug view has changed. See this FAQ.

Port Bug 528440 [Should skip windows that are closed but not yet destroyed when using nsIWindowMediator] to SeaMonkey

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Session Restore
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Misak Khachatryan, Assigned: Misak Khachatryan)

Tracking

Trunk
seamonkey2.1a1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.35 KB, patch
Misak Khachatryan
: review+
Misak Khachatryan
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Created attachment 438332 [details] [diff] [review]
patch

From parent bug:

nsIWindowMediator tracks windows until they are destroyed, but there's a brief
period when windows are closed without being destroyed yet. Session restore
should only care for windows that are open and should thus skip windows that
aren't.

I don't think this is relevant for real users, but it likely is relevant for
tests and could in fact be the cause for some intermittent failures we're
seeing.

I ran test on my Fedora 12, no failed test seen.
Attachment #438332 - Flags: superreview?(neil)
Attachment #438332 - Flags: review?(neil)

Updated

7 years ago
Attachment #438332 - Flags: superreview?(neil)
Attachment #438332 - Flags: superreview+
Attachment #438332 - Flags: review?(neil)
Attachment #438332 - Flags: review+

Comment 1

7 years ago
Comment on attachment 438332 [details] [diff] [review]
patch

>-      if (window.__SSi) {
>+      if (window.__SSi && !window.closed) {
Window closing is supposed to delete properties. But just in case, I'd prefer for you to check !window.closed first.
(Assignee)

Comment 2

7 years ago
Created attachment 438370 [details] [diff] [review]
for checkin

For checkin, carrying forward r+ and sr+ from Neil.
Attachment #438332 - Attachment is obsolete: true
Attachment #438370 - Flags: superreview+
Attachment #438370 - Flags: review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
(Assignee)

Comment 3

7 years ago
checking ping
(Assignee)

Comment 4

7 years ago
Pushed http://hg.mozilla.org/comm-central/rev/5a33b560c2d5
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Target Milestone: --- → seamonkey2.1a1
You need to log in before you can comment on or make changes to this bug.