Closed Bug 558722 Opened 14 years ago Closed 14 years ago

填表的自动完成出现异常

Categories

(Toolkit :: Form Manager, defect)

Other
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 428602

People

(Reporter: harcdy, Unassigned)

Details

User-Agent:       huawei c8100 320*240
Build Identifier: firefox 3.6.3 火狐中国版

例如:
1.填表历史记录里面保存了一条记录"123".
2.在输入框键入:"1".
3.Firefox自动完成功能给出提示:"123".
4.鼠标从提示信息上面移过,但是不选择Firefox的提示.
5.错误控制台出现异常信息:错误: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 825"  data: no]

Reproducible: Always

Steps to Reproduce:
例如:
1.填表历史记录里面保存了一条记录"123".
2.在输入框键入:"1".
3.Firefox自动完成功能给出提示:"123".
4.鼠标从提示信息上面移过,但是不选择Firefox的提示.
5.错误控制台出现异常信息:错误: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 825"  data: no]
Actual Results:  
错误: uncaught exception: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://global/content/bindings/autocomplete.xml :: onxblpopuphiding :: line 825"  data: no]
Version: unspecified → 3.6 Branch
Yeah, I can reproduce this. The key seems to be hovering over a dropdown entry so it's selected, and dismissing it when in that state. (On trunk it's line 847, but still onxblpopuphiding)
Status: UNCONFIRMED → NEW
Component: General → Form Manager
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: general → form.manager
Version: 3.6 Branch → unspecified
Mook noticed this is a dupe of 428602.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.