Automatic private browsing mode

RESOLVED DUPLICATE of bug 463027

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 463027
9 years ago
9 years ago

People

(Reporter: pisoir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)

Request for 2 features:

1. Private browsing should be tab-dependent and not browser dependent. It means, that in some tabs you could browse privately (without keeping history etc.) and in others normally. The problem is now, when you go back from private browsing to normal, the web pages are recalled and refreshed, i.e. if you were for example in the middle of writing something, everything is lost. 

2. It would be really nice feature if you could define a white-list of web pages, which would switch automatically to private browsing mode. After typing an address in the address bar, firefox would check if the web page is included in a "private browsing list" and automatically would switch to private browsing mode. 


Reproducible: Always




I know it would be mainly used for porn pages, but for example each time I want to go to an internet banking, or read mails, I have to manually switch to private mode. It would be nice, if I didn't have to.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 463027
You need to log in before you can comment on or make changes to this bug.