Last Comment Bug 559182 - 10.6 unit tests are not currently running
: 10.6 unit tests are not currently running
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Armen Zambrano [:armenzg] - Engineering productivity
:
Mentors:
Depends on:
Blocks: support-10.6_x64 darwin_unittests
  Show dependency treegraph
 
Reported: 2010-04-13 14:25 PDT by Armen Zambrano [:armenzg] - Engineering productivity
Modified: 2013-08-12 21:54 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
disable download_symbols for macosx64 talos tests (2.53 KB, patch)
2010-04-13 15:00 PDT, Mike Taylor [:bear]
no flags Details | Diff | Review
disable download_symbols for macosx64 talos tests (2.67 KB, patch)
2010-04-13 15:32 PDT, Mike Taylor [:bear]
armenzg: review-
Details | Diff | Review
disable download_symbols for macosx64 talos tests (1.96 KB, patch)
2010-04-13 15:49 PDT, Mike Taylor [:bear]
armenzg: review+
armenzg: checked‑in+
Details | Diff | Review
packageTests for 10.6 so we can run unit tests on talos (1.58 KB, patch)
2010-04-14 14:02 PDT, Armen Zambrano [:armenzg] - Engineering productivity
bear: review+
armenzg: checked‑in+
Details | Diff | Review
[WIP] really disable symbols if specified (2.04 KB, patch)
2010-04-14 14:06 PDT, Armen Zambrano [:armenzg] - Engineering productivity
no flags Details | Diff | Review
10.6 doesn't yet have symbols and we should not try to download them (1.82 KB, patch)
2010-04-15 08:46 PDT, Armen Zambrano [:armenzg] - Engineering productivity
lukasblakk+bugs: review+
armenzg: checked‑in+
Details | Diff | Review
production changes for 10.6 to generate packaged tests (1.55 KB, patch)
2010-04-15 13:01 PDT, Armen Zambrano [:armenzg] - Engineering productivity
coop: review+
Details | Diff | Review

Description Armen Zambrano [:armenzg] - Engineering productivity 2010-04-13 14:25:23 PDT
1) The step is run without failing:
   make: Nothing to be done for `buildsymbols'.
2) Nothing gets uploaded
3) The sendchange for it is send
4) The unit test fails because it can't find the file
> --14:09:09--  http://stage.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1271190183/firefox-3.7a5pre.en-US.mac64.crashreporter-symbols.zip
>            => `firefox-3.7a5pre.en-US.mac64.crashreporter-symbols.zip'
> Resolving stage.mozilla.org... 10.2.74.116
> Connecting to stage.mozilla.org|10.2.74.116|:80... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 14:09:10 ERROR 404: Not Found

Until this bug is not fixed we won't have unit tests for 10.6
Comment 1 Ben Hearsum (:bhearsum) 2010-04-13 14:28:00 PDT
I think you want download_symbols to be set to false in the Talos configs, actually?
Comment 2 Mike Taylor [:bear] 2010-04-13 15:00:41 PDT
Created attachment 438862 [details] [diff] [review]
disable download_symbols for macosx64 talos tests

disable download_symbols for macosx64 on staging and production
Comment 3 Mike Taylor [:bear] 2010-04-13 15:32:14 PDT
Created attachment 438871 [details] [diff] [review]
disable download_symbols for macosx64 talos tests
Comment 4 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-13 15:36:28 PDT
Comment on attachment 438871 [details] [diff] [review]
disable download_symbols for macosx64 talos tests

>diff --git a/mozilla2-staging/config.py b/mozilla2-staging/config.py
>--- a/mozilla2-staging/config.py
>+++ b/mozilla2-staging/config.py
>@@ -196,37 +196,34 @@ PLATFORM_VARS = {
>         },
>         'macosx64': {
>             'base_name': 'OS X 10.6 %(branch)s',
>             'mozconfig': 'macosx64/%(branch)s/nightly',
>             'profiled_build': False,
>             'builds_before_reboot': 5,
>             'build_space': 8,
>             'upload_symbols': True,
>-            'download_symbols': True,
>+            'download_symbols': False,
We need upload symbols to be False as well.


>-            'talos_masters': [
>-                ('talos-staging-master02.build.mozilla.org:9010', False),
>-                ('talos-staging-master02.build.mozilla.org:9012', False),
>-            ],
>+            'talos_masters': GLOBAL_VARS['talos_masters'],
>         },
Let's not take a change like this on bustage patch (yes, this one it is :D)


>             'build_space': 8,
>             'upload_symbols': True,
>-            'download_symbols': True,
>+            'download_symbols': False,
>
The same as previous comment.
Comment 5 Mike Taylor [:bear] 2010-04-13 15:49:36 PDT
Created attachment 438873 [details] [diff] [review]
disable download_symbols for macosx64 talos tests

set upload_symbols to False also and removed talos-master change for now - moving to a non-bustage patch
Comment 6 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-13 16:04:18 PDT
Comment on attachment 438873 [details] [diff] [review]
disable download_symbols for macosx64 talos tests

I will land this when pm becomes available.

Bear this bug is now all in my hands.
Thanks for your help.
Comment 7 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-14 11:10:35 PDT
Comment on attachment 438873 [details] [diff] [review]
disable download_symbols for macosx64 talos tests

http://hg.mozilla.org/build/buildbot-configs/rev/46dfd16e7371
Comment 8 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-14 14:02:25 PDT
Created attachment 439085 [details] [diff] [review]
packageTests for 10.6 so we can run unit tests on talos
Comment 9 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-14 14:06:59 PDT
Created attachment 439088 [details] [diff] [review]
[WIP] really disable symbols if specified

I still have to see if we actually need this patch.
Comment 10 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-14 14:32:33 PDT
Summary update:
* The fix commited this morning was not sufficient and was trying to fix the wrong problem (The problem is not that we don't produce symbols for 10.6)
* The actual problem is that packages are not being generated since opt_unittests are disabled for this platform
* The patches posted help this situation but I had not had enough time to see if the sendchanges are being picked up on the talos-staging-master and if triggered the unit tests over there
* I will continue this in the morning
Comment 11 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-14 14:33:08 PDT
Bear I am taking this if you don't mind :)
Comment 12 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-15 08:46:00 PDT
Created attachment 439247 [details] [diff] [review]
10.6 doesn't yet have symbols and we should not try to download them
Comment 13 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-15 10:59:51 PDT
Comment on attachment 439247 [details] [diff] [review]
10.6 doesn't yet have symbols and we should not try to download them

http://hg.mozilla.org/build/buildbot-configs/rev/72feb055bf31
Comment 14 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-15 11:00:28 PDT
Comment on attachment 439085 [details] [diff] [review]
packageTests for 10.6 so we can run unit tests on talos

http://hg.mozilla.org/build/buildbot-configs/rev/3bd75e03bba4
Comment 15 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-15 13:01:49 PDT
Created attachment 439314 [details] [diff] [review]
production changes for 10.6 to generate packaged tests
Comment 16 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-15 13:34:23 PDT
OK all looking good. I will wait to see builds triggered by devs and then see it run the unit tests on talos before I close this.
Comment 17 Armen Zambrano [:armenzg] - Engineering productivity 2010-04-16 06:35:09 PDT
These are being triggered.
I will file other bugs for the perma-oranges.

Note You need to log in before you can comment on or make changes to this bug.