WESTERN fonts are selected for a what's related sidebar

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: mik, Assigned: tetsuroy)

Tracking

({intl})

Trunk
mozilla0.9.5
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16 i686; en-US; m18) Gecko/20001002
BuildID:    2000100215

COntent is What's Related Sidebar is always displayed with
western fonts.  This Causes Localized strings to be unreadable

Reproducible: Always
Steps to Reproduce:
1. Make sure What's Related sidebar tab is open.
2. Go to the URL provided
3. See Some Suggested Links displayed in Western instead of Cyrillic


Actual Results:

Expected Results:  Mozilla sould choose the same encoding/autodetector for a
sidebar as for the page itself.
I see this with linux trunk build 2000110708.

Should this be in I18N?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
(Reporter)

Comment 3

18 years ago
This is still there.
What's related sidebar always has WESTERN fonts,
so Russian titles are unreadable.

Comment 4

18 years ago
I had the same problem with the Asturian langpack, the accentuated characters are 
displayed as question marks. However, I think the problem is because there are 
different panels.rdf files (under default profile, under profile, under locale 
ast-AS), too many I think! I was playing with them, and I changed one of them 
(I'll try to reproduce it), but the characters were displayed correctly. So, I 
think that there is some redundancy in the panels.rdf files, and some of them 
specify a character coding, and others other. Can be related to the fact that 
there is no separation yet between language and contents packs?

Comment 5

17 years ago
WFM in 9/30 branch build. REOPEN ifyou still see it. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Created attachment 51653 [details]
Screenshot showing WESTERN fonts in Whats related sidebar with russian content
(Reporter)

Comment 7

17 years ago
Reopening, since in 2001093008 sidebar still shows Russian letters with Latin
encodig, i.e. unreadable.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

17 years ago
This page is coming from the alexa server.  This is a normal iframe that is has 
a webpage with in it.  

http://xslt.alexa.com/data?cli=17&dat=nsacdt=t%3D0%26pane%3Dnswr6%26wid%3D5619&
url=http://www.urc.ac.ru

Load this in the content window and you get the same results.
Do you have the language pack? International issue.
Assignee: matt → yokoyama
Status: REOPENED → NEW
Component: Sidebar → Internationalization
QA Contact: sujay → andreasb
(Assignee)

Comment 9

17 years ago
Mikhail: matt's URL 
http://xslt.alexa.com/data?cli=17&dat=nsacdt=t%3D0%26pane%3Dnswr6%26wid%3D5619&url=http://www.urc.ac.ru
is "charset=iso-8859-1".  Change the Meta Charset to Cryllic should
fix your problem.  

Mozilla is working as designed.  

Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.5

Updated

17 years ago
Keywords: intl
QA Contact: andreasb → ruixu
(Assignee)

Comment 10

17 years ago
Mikhail:  I am marking this as INVALID.  Please reopen if you disagree.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 11

17 years ago
I'm marking this as verified according to Roy's comments for now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.