modifiers on menu items are case-sensitive

RESOLVED INVALID

Status

()

Core
XUL
P3
normal
RESOLVED INVALID
18 years ago
10 years ago

People

(Reporter: Dean Tessman, Assigned: David Hyatt)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
(Assigning to hyatt from CVS Blame)

Maybe this is as designed, and if it is then mark this as invalid because it's 
hopefully documented somewhere.  But as far as I can tell

http://lxr.mozilla.org/seamonkey/source/layout/xul/base/src/nsMenuFrame.cpp#1413

requires that the modifiers be specified as "shift", "alt", etc., and not 
"Shift", "Alt", "SHIFT", "ALT", or anything else.

Wouldn't it be easier for these to allow case-insensitivity?

Comment 1

18 years ago
"easier"?
(Reporter)

Comment 2

18 years ago
Sorry, I meant easier from a XUL designer's perspective.  As far as I can tell, 
the modifiers have to match case otherwise this code won't pick them up.

Comment 3

18 years ago
XUL is case sensitive. <menuitem/> is recognised in XUL, <MENUITEM/> isn't. I
don't think there is any added value in making this attribute value case
insensitive. Actually it looks like anywhere attributes have bound values we
prefer all lowercase over mixed case, so I guess it's a style issue too.

I suggest wontfix.
(Reporter)

Comment 4

18 years ago
Fine with me, as long as its well-documented somewhere.

Comment 5

18 years ago
It's close to being documented :-] (although, this doesn't actually
state that attribute values should be lower case).

http://www.mozilla.org/xpfe/xptoolkit/xulintro.html
  'A Word on Case and Namespaces, and Filetypes' 
    "... tags and attributes will, as a rule, always be lower case as
    suggested in the XHTML Working Draft."

cc: oeschger for doc issues.

Comment 6

18 years ago
->future
Target Milestone: --- → Future
(Reporter)

Comment 7

16 years ago
I filed this bug??  Geez, what was I on?  Marking INVALID
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.