Windows Live Calendar Timerange Category Tab-Switching partly broken

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: jra7b6, Unassigned)

Tracking

({qawanted, regression})

Details

(Whiteboard: [needs confirmation])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100414 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100414 Minefield/3.7a5pre

When attempting to look at my calender I can not see a weekly version only the day to day version. Also there is no way for me to access my skydrive from windows live either. This works on all other browsers just not this one. 

Reproducible: Always

Steps to Reproduce:
1.Log into a windows live mail account
2.Access calender
Actual Results:  
this is where i searched for calender options. they are no where to be found. Also after logging in there is no skydrive option. 

Expected Results:  
The software should allow me to view a calender on a monthly, and weekly basis. I should also be able to access files saved in my skydrive.
i see the same (at least the calender part). works fine on Fx 3.6.3 though.
i presume it's another user agent sniffing thingy (as it has been in the past). simly modifying general.useragent.extra.firefox does not help here though.
Component: Build Config → General
Product: Firefox → Core
QA Contact: build.config → general
Version: unspecified → Trunk

Comment 2

8 years ago
So as far as I understand, the steps to reproduce are:
1. Log into http://calendar.live.com/
2. Click Day, Week, Month, Agenda tabs.
Actual results: tabs not switched.
Expected resutls: tabs switched.

I tried it on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100417 Minefield/3.7a5pre Firefox/3.6 (the extra Firefox/3.6 added by me) and the tabs are indeed not switched, *unless* you click on a tab in the area not covered by text. Is it what everyone else sees?

This works in: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090901 Minefield/3.7a1pre Firefox/3.6

Fails in: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a1pre) Gecko/20090915 Minefield/3.7a1pre Firefox/3.6

I don't have builds in between downloaded, can someone else confirm what I see and figure out a smaller regression range?
Keywords: regression, regressionwindow-wanted
Summary: Windows live calender only allows you to see it in a day by day basis. → Windows live calendar only allows you to see it in a day by day basis.
(In reply to comment #2)
> Is it what everyone else sees?
Yes :-)

Broken per Range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bf0fdec8f43b&tochange=912c6ae3b70c
Likely by Bug 503943. Unsure if covered by already filed Regression Reports.
Blocks: 503943
Component: General → Event Handling
Keywords: regressionwindow-wanted
OS: Windows Vista → Windows XP
QA Contact: general → events
Summary: Windows live calendar only allows you to see it in a day by day basis. → Windows Live Calendar Timerange Category Tab-Switching partly broken
blocking2.0: --- → ?
Neil, per the above comment this is likely due to your fix for bug 503943, can you investigate? And blocking on this regression.
Assignee: nobody → enndeakin
blocking2.0: ? → betaN+

Comment 5

7 years ago
Likely due to IE having a different event model and, during capture, they expect events to fire in the 'IE way'. In other browsers, they expect setCapture to do nothing. Google Maps has or had a similar problem.

Comment 6

7 years ago
Can someone check if this was fixed by bug 582771?

Updated

7 years ago
Keywords: qawanted
Whiteboard: [needs confirmation]

Comment 7

7 years ago
I can't even get the Calendar page to load and display properly, so I can't test this, nor do much else with it.
(In reply to comment #7)
> I can't even get the Calendar page to load and display properly, so I can't
> test this, nor do much else with it.

Yep, this is not confirmable on Trunk unless Bug 610917 is fixed.

Updated

7 years ago
Depends on: 610917
Based on comment 5, sounds like this isn't a Firefox problem.

Someone needs to contact microsoft.
Assignee: enndeakin → english-us
blocking2.0: betaN+ → -
Component: Event Handling → English US
Product: Core → Tech Evangelism
QA Contact: events → english-us
Version: Trunk → unspecified

Comment 10

7 years ago
(In reply to comment #9)
> Based on comment 5, sounds like this isn't a Firefox problem.
> 
> Someone needs to contact microsoft.

Who might "someone" be? I don't know who has contacts over there, but someone cc'd here probably does.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Duplicate of this bug: 640192
This is WFM/Fixed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20121113065533 & Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121119030725
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.