Use of <limits> in ctypes breaks android build

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: mwu, Unassigned)

Tracking

({regression})

Trunk
All
Android
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Bionic doesn't provide the limits header or std::numeric_limits.
Hmm...  Can we provide a shim?  We have some content/ patches in flight that would use the limits header and std::numeric_limits, iirc.
(Reporter)

Comment 2

9 years ago
I think it might be possible, especially for limits which seems relatively simple. See also bug 556839 since we'll need to fix this issue to use e10s.
We'll need to fix this before we pull in a version of STL into the tree.
(Reporter)

Comment 4

9 years ago
We can probably borrow some appropriately licensed limits header or make our own. Rewriting code to not use std::numeric_limits isn't much of an option since the alternative is so much worse.
wontfixing this -- we'll have workarounds for STL in android (initially an alternate ndk, eventually an in-tree STL).
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.