Last Comment Bug 559868 - Switching from portrait to landscape mode while page is zoomed always displays tab sidebar
: Switching from portrait to landscape mode while page is zoomed always display...
Status: RESOLVED WORKSFORME
[MobFx1.1Betatestday]
:
Product: Fennec Graveyard
Classification: Graveyard
Component: Panning/Zooming (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
:
:
Mentors:
https://litmus.mozilla.org
: 588818 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 10:33 PDT by Henrik Skupin (:whimboo) [away 02/18 - 02/27]
Modified: 2010-09-22 06:59 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch (3.78 KB, patch)
2010-05-06 04:42 PDT, Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please)
no flags Details | Diff | Splinter Review

Description User image Henrik Skupin (:whimboo) [away 02/18 - 02/27] 2010-04-16 10:33:04 PDT
Fennec 1.1a2pre

If you have zoomed into a page at least by one level with the volume keys on your N900 device and switch from landscape mode to the portrait mode and back again, the tab sidebar is always shown.

Steps:
1. Open https://litmus.mozilla.org
2. Press the Vol+ button to zoom in
3. Switch to portrait mode
4. Switch back to landscape mode

After step 4 the tab sidebar will always be displayed.
Comment 1 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-05-06 03:46:07 PDT
That a general resize problem. I can see that on desktop too just by resizing my window from normal to maximize.
Comment 2 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-05-06 04:42:33 PDT
Created attachment 443854 [details] [diff] [review]
Patch
Comment 3 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-05-06 04:43:22 PDT
The attached patch is mostly a workaround, I think the right fix involved adding a MozBeforeResize event to the platform.
Comment 4 User image Mark Finkle (:mfinkle) (use needinfo?) 2010-05-06 11:41:32 PDT
I am not like the patch that much. It seems like too much of a workaround. I don't think I'd want to take it for Fennec 1.1 in any case.
Comment 5 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-05-12 05:08:26 PDT
Another step to reproduce the bug is:
 * launch Fennec on about:home
 * double click on the fennec/firefox logo
 * go to portrait
 * go back to landscape
Comment 6 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-05-12 08:16:53 PDT
This happen only on trunk, not 1.9.2. This won't block 1.1.
Comment 7 User image Mark Finkle (:mfinkle) (use needinfo?) 2010-05-19 07:13:19 PDT
Removing "qablocker" since this is not a Fennec 1.1 issue
Comment 8 User image Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2010-08-19 13:35:46 PDT
*** Bug 588818 has been marked as a duplicate of this bug. ***
Comment 9 User image Mark Finkle (:mfinkle) (use needinfo?) 2010-09-21 14:32:30 PDT
I can't reproduce this bug anymore. Can anyone else? Note: zooming is busted for about:home, so you need to use content pages.
Comment 10 User image Matt Brubeck (:mbrubeck) 2010-09-21 14:33:54 PDT
WFM now too.

Note You need to log in before you can comment on or make changes to this bug.