Closed Bug 559950 Opened 10 years ago Closed 10 years ago

[OOPP] crash in [@ nsPluginInstanceOwner::Paint(tagRECT const&, HDC__*) ]

Categories

(Core :: Plug-ins, defect)

1.9.2 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 536020

People

(Reporter: jbecerra, Assigned: bent.mozilla)

Details

(Whiteboard: [to be fixed by bug 536020])

While testing 3.6.4(build1), Bing Bar toolbar installed, Silverlight 4, Flash 10.1 rc. I had some silverlight content in one tab, and an msn.com article in another, and I was trying to view a video in Hulu. I full screened the video while the video was playing, then I paused the video within full screen, then I pressed the ESC key.

The browser hung, and I left it there for a good half hour. I had to kill the plugin-container process. Shortly there after the browser crashed.

http://crash-stats.mozilla.com/report/index/7ab06c6a-88a2-493d-a46c-d9e2b2100416

This situation is not too hard to reproduce, but I think I have gotten different crash signatures.
Bent, can you catch this in recording?
Assignee: nobody → bent.mozilla
blocking1.9.2: --- → ?
Juan - still easy to reproduce? Do we still need to catch this in recording?

I think we would have to block on this if it's easy to reproduce. Hulu's a pretty big site, and people use it full screen.
blocking1.9.2: ? → .4+
The crash is pretty easy to reproduce. I've tried on my Mac Mini hardware as well as on a VM. This is the crash ID I got in my VM for instance:

http://crash-stats.mozilla.com/report/index/c28317d9-6acb-4d02-a0e7-031362100421

However, if I remove the Bing Toolbar, I cannot reproduce the problem at all.
Likely a dupe of bug 559384? Can this be reproduced on a trunk nightly? (i'll try here myself, but the STR is a little vague.)
I can't reproduce with 3.6.4, SL4, bing bar and hulu.
And no, I don't think this can be a dup of that bug: this one is about plugin painting, and is a browser-side crash, not a hang.
I experience the problem with: 3.6.4 installed with the Bing Bar extension/toolbar (http://www.microsoft.com/toolbar/; Silverlight 4; Flash 10.1 rc1 or rc2.

Steps:
1. Launch the browser and visit http://www.silverlight.net/showcase/
2. Pick one of those (I like http://www.kalentyr.ru/metro/)
3. Allow Fx to open pop-ups if prompted to. You should now have the two tabs above open.
4. Open a third tab http://www.hulu.com/ and click on any video to play it.
5. Click on the Full Screen icon within the hulu video player.
6. Click on the pause button while in full screen video.
7. Press the ESC key

It usually takes me three repetitions of steps 5, 6, 7, but it will eventually hang, at which point I have to end the plugin-container process.
I spent a bit trying to record this. I ended up recording bug 536020 instead, but I think that the crash after the hang probably has the same root cause as that bug.

I never could reproduce the hang, though.
Whiteboard: [to be fixed by bug 536020]
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536020
Removing blocking flag as we are tracking the original.
blocking1.9.2: .4+ → ---
You need to log in before you can comment on or make changes to this bug.