Rename LOpcode enums in NativeARM.cpp

RESOLVED FIXED in Future

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: edwsmith, Unassigned)

Tracking

unspecified
Future
ARM
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tamarin, fixed-in-tracemonkey)

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

8 years ago
Blocks: 504506
(Reporter)

Updated

8 years ago
Assignee: nobody → edwsmith
Target Milestone: --- → Future
(Reporter)

Comment 1

8 years ago
Created attachment 443612 [details] [diff] [review]
Automatic rename plus manual alignment fixes.
Attachment #443612 - Flags: review?(nnethercote)
Attachment #443612 - Flags: feedback?(Jacob.Bramley)
Comment on attachment 443612 [details] [diff] [review]
Automatic rename plus manual alignment fixes.

>-        case LIR_fadd:      FADDD(rr,ra,rb);    break;
>-        case LIR_fsub:      FSUBD(rr,ra,rb);    break;
>-        case LIR_fmul:      FMULD(rr,ra,rb);    break;
>-        case LIR_fdiv:      FDIVD(rr,ra,rb);    break;
>+        case LIR_addd:      FADDD(rr,ra,rb);    break;
>+        case LIR_subd:      FSUBD(rr,ra,rb);    break;
>+        case LIR_muld:      FMULD(rr,ra,rb);    break;
>+        case LIR_divd:      FDIVD(rr,ra,rb);    break;

FADDD et al are no longer appropriate.  I don't know why the 'D' suffix was
already there... would ADDD et al suffice?

r=me with that fixed, the rest looks fine.
Attachment #443612 - Flags: review?(nnethercote) → review+
(Reporter)

Comment 3

8 years ago
I believe those are the correct names for the ARM instructions.  there's FADD for float and FADDD for double.
(In reply to comment #3)
> I believe those are the correct names for the ARM instructions.  there's FADD
> for float and FADDD for double.

Oh, ok.  Leave them as is then!
Comment on attachment 443612 [details] [diff] [review]
Automatic rename plus manual alignment fixes.

Looks sensible to me.

The double-precision instructions do indeed get a "D" suffix, though we tend to deal in UAL/ARMv7 notation where possible, which would be "VADD.F64". I didn't see any value in changing all the macro names so the old-style names persist!
Attachment #443612 - Flags: feedback?(Jacob.Bramley) → feedback+
(Reporter)

Comment 6

8 years ago
NJ: http://hg.mozilla.org/projects/nanojit-central/rev/f7a0d7ffe073
Assignee: edwsmith → nobody
Whiteboard: fixed-in-nanojit
(Reporter)

Comment 7

8 years ago
TR: http://hg.mozilla.org/tamarin-redux/rev/44a5219a43bc
Whiteboard: fixed-in-nanojit → fixed-in-nanojit, fixed-in-tamarin
TM: http://hg.mozilla.org/tracemonkey/rev/e090f2679b68
Whiteboard: fixed-in-nanojit, fixed-in-tamarin → fixed-in-nanojit, fixed-in-tamarin, fixed-in-tracemonkey

Comment 9

8 years ago
http://hg.mozilla.org/mozilla-central/rev/e090f2679b68
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Component: Nanojit → Nanojit
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.