Status

()

P1
critical
VERIFIED DUPLICATE of bug 52397
18 years ago
18 years ago

People

(Reporter: pierre, Assigned: gagan)

Tracking

({crash, platform-parity, top100})

Trunk
PowerPC
Mac System 8.5
crash, platform-parity, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Per ekrock's request at the Layout meeting, I started surfing porn sites. Don't 
panic: we're still in the "soft" category.

- Install PR3 on a Mac. If it is already installed, clean the prefs (in the prefs 
folder + user folder) or make sure that you don't have any Playboy cookies.
- Go to http://www.playboy.com/
==> The server opens a popup window and the app crashes.

The crash occurs in nsHTTPServerListener::OnDataAvailable() when calling 
mChannel->ReportProgress() because mChannel is null.
(Reporter)

Comment 1

18 years ago
Created attachment 16687 [details]
stack trace
(Reporter)

Comment 2

18 years ago
This crash doesn't happen on Win98.

Nominating for RTM because it's a top100 site. I guess we should fix it even 
though no reporter is going to complain about it in the newspapers (with the 
exception of Hugh Hefner, maybe?).
Keywords: pp, rtm, top100
Priority: P3 → P1

Updated

18 years ago
Keywords: crash
heh. fwiw, i don't crash going to the playboy site. then again, i'm using
optimized commercial branch bits (on 9.0). were you using trunk bits?
(Reporter)

Comment 4

18 years ago
Nope, I was using PR3 on MacOS 9. I'll try the branch tips too.
(Reporter)

Comment 5

18 years ago
I downloaded today's mozilla-mac-MN6 (2000-10-10-08) from mozilla.org and it did 
not crash. I can't download the real commercial build from ftp://sweetlou because 
I'm behind the firewall.

If the Netscape build doesn't crash (make sure you don't have any cookie, quit 
and relaunch), then close the bug as WorksForMe...
(Assignee)

Comment 6

18 years ago
Oh come on... if you want to surf playboy, at least surf with the latest builds 
:)

*** This bug has been marked as a duplicate of 52397 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified, this is a duplicate of bug 52397 "Crashing in [@
nsHTTPServerListener::OnDataAvailable]"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.