Make history use the same core places files as bookmarks

RESOLVED DUPLICATE of bug 1378089

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 1378089
8 years ago
4 months ago

People

(Reporter: Robert Kaiser, Unassigned, Mentored)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [history][2012 Fall Equinox][lang=js/xul])

(Reporter)

Description

8 years ago
Once bug 498596 lands, we can make bookmarks and history use the same set of core places files, like for example the tree implementation and view, or PlacesUIUtils.

See bug 498596 comment #14 for some numbers aligned with this - additionally, it eases maintenance by only needing to update a single set of places files to keep up with Firefox work.

The bookmarks patches already import the new, more complete files in a shared place to make this followup easier.
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Bug 580656 is now about the to-be-shared new places core, only that part is needed to work on making history use it as well.
Depends on: 580656
No longer depends on: 498596
(Reporter)

Comment 2

6 years ago
Neil, i thought you had a shot at this at some time, but I see that we still have controller.js, tree.xml, treeView.js on both places/ and history/ - if those both are used, I think we should at least make this a mentored bug. Neil, would you mentor it?

Updated

6 years ago
Whiteboard: [history] → [history][2012 Fall Equinox]

Comment 3

6 years ago
(In reply to Robert Kaiser from comment #2)
> Neil, i thought you had a shot at this at some time, but I see that we still
> have controller.js, tree.xml, treeView.js on both places/ and history/ - if
> those both are used, I think we should at least make this a mentored bug.
> Neil, would you mentor it?
I could I suppose. I assume places.css could be shared too?
(Reporter)

Comment 4

6 years ago
(In reply to neil@parkwaycc.co.uk from comment #3)
> I could I suppose. I assume places.css could be shared too?

Good, thanks, I'll add the entries for this.
On places.css: Yes, probably, I didn't looks through all files in those directories, just caught some major ones I know. Whoever works on this should check what in suite/common/history/ is duplicated in suite/common/places/ (ideally code-wise, not just file-name-wise) and make us use the places/ versions in the history stuff as well.
Whiteboard: [history][2012 Fall Equinox] → [history][2012 Fall Equinox][mentor=Neil][lang=js/xul]

Updated

6 years ago
Blocks: 486011
(Assignee)

Updated

4 years ago
Mentor: neil.corlett
Whiteboard: [history][2012 Fall Equinox][mentor=Neil][lang=js/xul] → [history][2012 Fall Equinox][lang=js/xul]

Updated

4 years ago
Mentor: neil.corlett → neil
Depends on: 917725
Done in Bug 1378089
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1378089
You need to log in before you can comment on or make changes to this bug.