History sidebar does not update when deleting items while in "By Last Visited" view

RESOLVED DUPLICATE of bug 549192

Status

()

RESOLVED DUPLICATE of bug 549192
9 years ago
9 years ago

People

(Reporter: fehe, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100419 Minefield/3.7a5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100419 Minefield/3.7a5pre

If items in the history sidebar are delete while in the "By Last Visited" view, the sidebar does not update to indicate any items have been deleted, until the sidebar is closed and reopened.

Regression window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=059e9961a122&tochange=475768f37b1a

Likely a regression from bug 492797



Reproducible: Always

Steps to Reproduce:
1. Open history sidebar
2. Toggle "View" setting to "By Last Visited"
3. Right-click and delete a history item.  Notice that it does not disappear
4. Close an reopen the history sidebar.  Notice that item from Step 3 is gone.
(Reporter)

Updated

9 years ago
Blocks: 492797
Keywords: regression
Version: unspecified → Trunk
Dupe of bug 549192 ?
(Reporter)

Comment 2

9 years ago
I guess.  Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 549192
You need to log in before you can comment on or make changes to this bug.