The default bug view has changed. See this FAQ.

install-module.pl fails to install DateTime with modern versions of Module::Build and CPAN

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Installation & Upgrading
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

Bugzilla 3.6
Bug Flags:
approval +
approval3.6 +

Details

Attachments

(1 attachment, 1 obsolete attachment)

v1
1.13 KB, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
I recently had to install the latest Module::Build and CPAN while using install-module.pl on an old Perl (5.8.1), in order to get DateTime to install. But when trying to install DateTime, I got an error, like this:

ERROR: Can't create '/opt/perl-5.8.1/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi'

As you can see, it was trying to write to the global dir instead of the local one.

So apparently, we also need to set mbuild_install_arg, or possibly set mbuildpl_arg instead of mbuild_arg.
(Assignee)

Comment 1

7 years ago
Created attachment 440046 [details] [diff] [review]
v1

Wow, that took a REALLY long time to figure out! Okay, so the problem is that newer versions of Module::Build have a different behavior for install_base. So now I set arguments in such a way that they will work on all versions of Module::Build--in particular, I had to set install_path for the "lib" and "arch" dirs both, and then I also had to make sure that mbuild_install_arg was also set.

I could have just done mbuildpl_arg instead, but that would only have been run once by CPAN, even if we were doing multiple install-module.pl calls across various different Bugzilla installations on the same machine, so that could have been disastrous (it would have installed into the old Bugzilla directory when the user was trying to install into the new Bugzilla directory).
Assignee: installation → mkanat
Status: NEW → ASSIGNED
Attachment #440046 - Flags: review+
(Assignee)

Updated

7 years ago
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 2

7 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Install/CPAN.pm
Committed revision 7132.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Install/CPAN.pm
Committed revision 7086.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 3

7 years ago
Created attachment 445600 [details]
hackersinci

hackersinci
Attachment #445600 - Flags: review+

Updated

7 years ago
Attachment #445600 - Attachment is obsolete: true
Attachment #445600 - Attachment is patch: false
Attachment #445600 - Flags: review+

Updated

7 years ago
Attachment #445600 - Attachment mime type: text/plain → image/jpg
You need to log in before you can comment on or make changes to this bug.