Links inside frame not working [WARNING: save attachments locally!]]

VERIFIED DUPLICATE of bug 53708

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED DUPLICATE of bug 53708
18 years ago
18 years ago

People

(Reporter: Phil Schwartau, Assigned: Eric Pollmann)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
Using Mozilla binaries 2000100908 on WinNT, 2000100909 on Linux.
At the left of http://www.toyota.com, there are links for the various
Toyota models: Avalon, Camry, Celica, and so on. These are not working.


When you click on any one of these links in NN4.x, you get a new page
devoted to the model you chose. However, in Mozilla, nothing happens.
Furthermore, the whole left side of the web page becomes unresponsive. 
That is, the frame there no longer responds to the mouse. For example, 
you can't change the focus to another model of car; you can't enter any 
text into the "site search" edit box. Other parts of the browser seem to 
remain reponsive, though, and I am able to escape the site...


The HTML uses <FRAMES>, which in turn use <FRAMES>, etc. in a nested way.
I will attach the HTML for some of these below.
(Reporter)

Comment 1

18 years ago
Created attachment 16720 [details]
Here is a reduced testcase containing two frames
(Reporter)

Comment 2

18 years ago
Created attachment 16722 [details]
Here is the second of the two frames above, as a standalone
(Reporter)

Comment 3

18 years ago
OK, THE ABOVE ATTACHMENTS DON'T WORK WHILE RESIDING ON THE BUGZILLA SERVER !!!
YOU MAY CRASH IF YOU CLICK ON THEM !!! 


You have to save them LOCALLY. Even then, on WinNT, sometimes even NN4.x
has trouble with them - you may end up with a hanging, invisible Netscape
process that you will have to kill. But when I use Mozilla to open them 
(LOCALLY!), attachment 16720 [details] exhibits the bug: the links don't work. 
By contrast, attachment 16722 [details] functions : if you click on a link, it will
come up successfully - but in a NEW WINDOW, which is strange.


The structure of attachment 16720 [details] is: 


<HTML>
<BASE HREF="http://www.toyota.com/">
<HEAD></HEAD>

<FRAMESET etc.>
  <FRAME SRC="/top_bar.html"   etc.>
  <FRAME 
SRC="/cgi-bin/lower_frame.cgi?low_frame=welcome/welcome.tmpl&data_frame=%2fwelco
me%2fintro_welcome.html"    etc.>   
</FRAMESET>

</HTML>


Attachment 16722 [details] is simply the HTML for the second frame as a standalone 
("/cgi-bin/lower_frame.cgi  etc. etc. "), with the following tag added: 
<BASE HREF="http://www.toyota.com/">
(Reporter)

Comment 4

18 years ago
Created attachment 16735 [details]
HTML of attachment 16720 [details] (doesn't work in Mozilla)
(Reporter)

Comment 5

18 years ago
Created attachment 16736 [details]
HTML of attachment 16722 [details] (works in Mozilla - but in new window)
(Reporter)

Updated

18 years ago
Summary: Links inside frame not working → Links inside frame not working [WARNING: save attachments locally!]]
(Assignee)

Comment 6

18 years ago
This is already reported as bug 53708.  I have a fix that I'd like to see get in
for rtm - just need PDT approval.

*** This bug has been marked as a duplicate of 53708 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified, this is a duplicate of bug 53708 "links loads wrong page into frame /
link doesn't load page."
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.