Closed Bug 560431 Opened 10 years ago Closed 10 years ago

Scroll position isn't regained from history after clicking on internal link

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
x86
Windows 7
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 479862

People

(Reporter: martijn.martijn, Assigned: vingtetun)

References

()

Details

(Whiteboard: mobile-triage)

To reproduce:
- Visit http://en.wikipedia.org/wiki/Hyperlink
- Scroll down to the table of contents
- Click on the "1.1.1 Anchor" link, the page scrolls down to the anchor in that page
- Go back in history

Expected result:
The scroll position of the page should return as just before the link was clicked upon.

Actual result:
The scroll position is not regained, returns at the start of the page.
This sounds like a regression. We have code that tracks the scroll position of the underlying browser and we update the tile-canvas scroll position.
Depends on: 479862
I'm also having link clicking problems, after the steps to reproduce. I guess those could be fixed by bug 47982 too then.
Er, I meant bug 479862 in comment 3.
Whiteboard: mobile-triage
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479862
dupe, v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.